计划想考个PAT,考虑到自己C++基本功不熟,就在这儿做一些笔记以方便我后面过来看看:
Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification: Each input file contains one test case. Each case contains a pair of integers a and b where ?10 ?6 ?? ≤a,b≤10 ?6 ?? . The numbers are separated by a space.
Output Specification: For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input: -1000000 9 Sample Output: -999,991
题目思路: 两个数字相加得到的结果字符串化,然后每隔三个插个逗号,但是要防止在负号后面插逗号
#include <iostream>
using namespace std;
int main(){
int a, b;
string sumStr, ans;
cin >> a >> b;
sumStr = to_string(a + b);
for(int i = 0; i < sumStr.size(); i++){
char n = sumStr[sumStr.size() - 1 - i];
if(i % 3 == 0 && i >= 3 && n != '-'){
ans += ',';
}
ans += n;
}
for(int i = 0;i < ans.size(); i++){
cout << ans[ans.size() - 1 - i];
}
return 0;
}
但其实这儿的代码还是有待改进的: 进行了一定量的优化了之后
#include <iostream>
using namespace std;
int main(){
int a, b;
string sumStr, ans;
cin >> a >> b;
sumStr = to_string(a + b);
for(int i = sumStr.size() - 1,j = 0; i >= 0 ; i--){
ans = sumStr[i] + ans;
++j;
if(j % 3 == 0 && i && sumStr[i - 1] != '-'){
ans = ',' + ans;
}
}
cout << ans << endl;
return 0;
}
|