一、题目
本题的基本要求非常简单:给定 N 个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是 [?1000,1000] 区间内的实数,并且最多精确到小数点后 2 位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式: 输入第一行给出正整数 N(≤100)。随后一行给出 N 个实数,数字间以一个空格分隔。
输出格式: 对每个非法输入,在一行中输出 ERROR: X is not a legal number,其中 X 是输入。最后在一行中输出结果:The average of K numbers is Y,其中 K 是合法输入的个数,Y 是它们的平均值,精确到小数点后 2 位。如果平均值无法计算,则用 Undefined 替换 Y。如果 K 为 1,则输出 The average of 1 number is Y。
输入样例 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例 2:
2
aaa -9999
输出样例2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
二、代码
#include<iostream>
#include<string>
#include<sstream>
#include<iomanip>
#include<algorithm>
using namespace std;
bool isNumber(string s)
{
istringstream sin(s);
double test;
return sin >> test && sin.eof();
}
int getnum(string f)
{
if (f.find('.') > f.size())
{
return 0;
}
reverse(f.begin(), f.end());
int i = 0;
while (f[i] != '.')
{
i++;
}
if (i == f.size())
{
return 0;
}
else
{
return i;
}
}
int main()
{
int n;
cin >> n;
stringstream ss;
string data, s;
getline(cin, s);
int flag = 0;
double sum = 0;
getline(cin, s);
ss << s;
while (ss >> data)
{
if (isNumber(data))
{
if (stod(data) <= 1000 && stod(data) >= -1000)
{
if (getnum(data) > 2)
{
cout << "ERROR: " << data << " is not a legal number" << endl;
}
else
{
sum += stod(data);
flag++;
}
}
else
{
cout << "ERROR: " << data << " is not a legal number" << endl;
}
}
else
{
cout << "ERROR: " << data << " is not a legal number" << endl;
}
}
if (flag != 0)
{
if (flag == 1)
{
cout << "The average of " << flag << " number is " << fixed << setprecision(2) << sum / flag;
}
else
{
cout << "The average of " << flag << " numbers is " << fixed << setprecision(2) << sum / flag;
}
}
else
{
cout << "The average of 0 numbers is Undefined";
}
return 0;
}
三、遇到的问题以及相应的参考链接
1.使用题给编译器编译遇到报错:‘reverse’ was not declared in this scope 链接: 求指点,同样的程序,在dev里面运行为啥会出现[Error] ‘reverse’ was not declared in this scope. 2.cout的格式化输出 链接: cout格式化输出(输出格式)完全攻略 3.判断字符串是否为数字类型 链接: PAT甲级备考手册(附常见题型分类 C++实现) 4.编译时弹出窗口抛出异常:Expression:string subscript out of range 目前确定是判断小数位数函数的问题,将整数单独处理则不会抛出此异常,具体原因仍不清楚
|