IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> POJ2704 HDU1208 LA3390 Pascal‘s Travels【递推+记忆化搜索】 -> 正文阅读

[C++知识库]POJ2704 HDU1208 LA3390 Pascal‘s Travels【递推+记忆化搜索】

Pascal’s Travels
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5656 Accepted: 2538

Description

An n x n game board is populated with integers, one nonnegative integer per square. The goal is to travel along any legitimate path from the upper left corner to the lower right corner of the board. The integer in any one square dictates how large a step away from that location must be. If the step size would advance travel off the game board, then a step in that particular direction is forbidden. All steps must be either to the right or toward the bottom. Note that a 0 is a dead end which prevents any further progress.

Consider the 4 x 4 board shown in Figure 1, where the solid circle identifies the start position and the dashed circle identifies the target. Figure 2 shows the three paths from the start to the target, with the irrelevant numbers in each removed.
在这里插入图片描述
Figure 1 ????????????????????????????? Figure 2

Input

The input contains data for one to thirty boards, followed by a final line containing only the integer -1. The data for a board starts with a line containing a single positive integer n, 4 <= n <= 34, which is the number of rows in this board. This is followed by n rows of data. Each row contains n single digits, 0-9, with no spaces between them.
Output

The output consists of one line for each board, containing a single integer, which is the number of paths from the upper left corner to the lower right corner. There will be fewer than 263 paths for any board.

Sample Input

4
2331
1213
1231
3110
4
3332
1213
1232
2120
5
11101
01111
11111
11101
11101
-1

Sample Output

3
0
7

Hint

Brute force methods examining every path will likely exceed the allotted time limit. 64-bit integer values are available as long values in Java or long long values using the contest’s C/C++ compilers.

Source

Mid-Central USA 2005

问题链接POJ2704 HDU1208 LA3390 Pascal’s Travels
问题简述:给定一个棋盘,棋盘上的每个数字表示需要走几格,只能向下或向右走。问从左上角走到右下角有几种走法?
问题分析:一种方法是用递推实现,通常称为DP实现;另外一种方法是用DFS实现,用记忆化搜索来加快速度。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* POJ2704 HDU1208 LA3390 Pascal's Travels */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 34;
char b[N][N + 1];
long long dp[N][N];
int n;

int main()
{
    while (~scanf("%d", &n) && n != -1) {
        getchar();
        for (int i = 0; i < n; i++) {
            scanf("%s", b[i]);
            for (int j = 0; j < n; j++)
                b[i][j] -= '0';
        }

        memset(dp, 0, sizeof dp);
        dp[0][0] = 1;
        for (int i = 0; i < n; i++)
            for (int j = 0; j < n; j++)
                if (b[i][j]) {
                    if (i + b[i][j] < n)
                        dp[i + b[i][j]][j] += dp[i][j];
                    if (j + b[i][j] < n)
                        dp[i][j + b[i][j]] += dp[i][j];
                }

        printf("%lld\n", dp[n - 1][n - 1]);
    }

    return 0;
}

AC的C++语言程序如下:

/* POJ2704 HDU1208 LA3390 Pascal's Travels */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int drow[] = {0, 1};
const int dcol[] = {1, 0};
const int N = 34;
char b[N][N + 1];
int vis[N][N];
long long dp[N][N];
int n;

long long dfs(int row, int col)
{
    if (row < 0 || row >= n || col < 0 || col >= n) return 0;
    if (vis[row][col]) return dp[row][col];
    vis[row][col] = 1;
    for (int i = 0; i < 2; i++)
        dp[row][col] += dfs(row + (b[row][col] - '0') * drow[i], col + (b[row][col] - '0') * dcol[i]);
    return dp[row][col];

}

int main()
{
    while (~scanf("%d", &n) && n != -1) {
        getchar();
        for (int i = 0; i < n; i++)
            scanf("%s", b[i]);

        memset(vis, 0, sizeof vis);
        memset(dp, 0, sizeof dp);
        vis[n - 1][n - 1] = 1;
        dp[n - 1][n - 1] = 1;

        printf("%lld\n", dfs(0, 0));
    }

    return 0;
}
  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-08-02 10:37:50  更:2021-08-02 10:39:59 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年5日历 -2024/5/9 13:07:03-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码