IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> A1035 Password -> 正文阅读

[C++知识库]A1035 Password

问题描述

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase).
One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

输入格式

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

输出格式

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

输入样例1

3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
(结尾无空行)

输出样例1

2
Team000002 RLsp%dfa
Team000001 R@spodfa
(结尾无空行)

输入样例2

1
team110 abcdefg332
(结尾无空行)

输出样例2

There is 1 account and no account is modified
(结尾无空行)

输入样例3

2
team110 abcdefg222
team220 abcdefg333
(结尾无空行)

输出样例3

There are 2 accounts and no account is modified
(结尾无空行)

C语言代码

#include<stdio.h>
#include<string.h>

//结构体存放修改后的用户信息
struct User{
	char name[15];
	char password[15];
}user[1010];

int main(){
	int n, count = 0; //count记录修改的用户信息数
	char name[15], password[15];
	scanf("%d", &n);
	
    //循环输入用户信息
	for(int j = 0; j < n; j++){
		bool jud = false; //判断是否进行了修改操作
		scanf("%s%s", name, password);	
	//遍历数组password,找到需要修改的部分
		for(int i = 0; i < strlen(password); i++){
			if(password[i] == '1'){
				password[i] = '@';
				jud = true;
			}
			else if(password[i] == '0'){
				password[i] = '%';
				jud = true;
			}
			else if(password[i] == 'l'){
				password[i] = 'L';
				jud = true;
			}
			else if(password[i] == 'O'){
				password[i] = 'o';
				jud = true;
			}
		}
	//如果进行了修改,则将信息存放在用户数组中
		if(jud){ 
			strcpy(user[count].name , name);
			strcpy(user[count].password , password);
			count++;
		}
	}
   //当没有修改记录时
	if(count == 0){
        if(n==1)
            printf("There is %d account and no account is modified", n);
        else
            printf("There are %d accounts and no account is modified", n);
    }
	else 
		printf("%d\n", count);
	for(int i = 0; i < count; i++){
		if(i != count-1)
			printf("%s %s\n", user[i].name, user[i].password);
		else
			printf("%s %s", user[i].name, user[i].password);
	}
	return 0;
}

注意:

  1. 阅读题目时,看清楚题目需求,情况要分类完全,例如有无修改信息、无修改信息,但n单复数不同时等多种情况

Password原题

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-08-21 15:10:21  更:2021-08-21 15:11:54 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/17 22:20:21-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码