问题描述
To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.
输入格式
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.
输出格式
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.
输入样例1
3 Team000002 Rlsp0dfa Team000003 perfectpwd Team000001 R1spOdfa (结尾无空行)
输出样例1
2 Team000002 RLsp%dfa Team000001 R@spodfa (结尾无空行)
输入样例2
1 team110 abcdefg332 (结尾无空行)
输出样例2
There is 1 account and no account is modified (结尾无空行)
输入样例3
2 team110 abcdefg222 team220 abcdefg333 (结尾无空行)
输出样例3
There are 2 accounts and no account is modified (结尾无空行)
C语言代码
#include<stdio.h>
#include<string.h>
struct User{
char name[15];
char password[15];
}user[1010];
int main(){
int n, count = 0;
char name[15], password[15];
scanf("%d", &n);
for(int j = 0; j < n; j++){
bool jud = false;
scanf("%s%s", name, password);
for(int i = 0; i < strlen(password); i++){
if(password[i] == '1'){
password[i] = '@';
jud = true;
}
else if(password[i] == '0'){
password[i] = '%';
jud = true;
}
else if(password[i] == 'l'){
password[i] = 'L';
jud = true;
}
else if(password[i] == 'O'){
password[i] = 'o';
jud = true;
}
}
if(jud){
strcpy(user[count].name , name);
strcpy(user[count].password , password);
count++;
}
}
if(count == 0){
if(n==1)
printf("There is %d account and no account is modified", n);
else
printf("There are %d accounts and no account is modified", n);
}
else
printf("%d\n", count);
for(int i = 0; i < count; i++){
if(i != count-1)
printf("%s %s\n", user[i].name, user[i].password);
else
printf("%s %s", user[i].name, user[i].password);
}
return 0;
}
注意:
- 阅读题目时,看清楚题目需求,情况要分类完全,例如有无修改信息、无修改信息,但n单复数不同时等多种情况
Password原题
|