IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PTA甲级 1081 Rational Sum (C++) -> 正文阅读

[C++知识库]PTA甲级 1081 Rational Sum (C++)

Given N N N rational numbers in the form numerator/denominator, you are supposed to calculate their sum.

Input Specification:

Each input file contains one test case. Each case starts with a positive integer N ( ≤ 100 ) N (≤100) N(100), followed in the next line N N N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.

Output Specification:

For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator, and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.

Sample Input 1:

5
2/5 4/15 1/30 -2/60 8/3

Sample Output 1:

3 1/3

Sample Input 2:

2
4/3 2/3

Sample Output 2:

2

Sample Input 3:

3
1/3 -1/6 1/8

Sample Output 3:

7/24

Caution:

注意【数据溢出】以及【求最大公约数】问题。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-22 21:40:27
// All rights reserved.

#include <iostream>
#include <vector>
#include <cmath>

using namespace std;

long long gcd(long long a, long long b){
    if(a < b) swap(a, b);

    if(a % b == 0) return b;
    else return gcd(b, a % b);
}

struct Num{
    long long numerator;
    long long denominator;

    Num(long long n, long long d){
        numerator = n;
        denominator = d;

        if(n == 0) return;

        long long pos = gcd(abs(numerator), denominator);

        numerator /= pos;
        denominator /= pos;
    }

    ~Num(){}
};

Num add(Num &a, Num &b){
    long long numerator = a.numerator * b.denominator + b.numerator * a.denominator;
    long long denomiator = a.denominator * b.denominator;

    Num ans(numerator, denomiator);
    return ans;
}

int main(){
    int n;

    scanf("%d", &n);
    Num ans(0, 1);

    for(int i = 0; i < n; ++i){
        int numerator, denominator;

        scanf("%d/%d", &numerator, &denominator);
        Num tmp((long long)numerator, (long long)denominator);
        ans = add(ans, tmp);

    }

    long long integer, frational;
    integer = ans.numerator / ans.denominator;
    frational = ans.numerator % ans.denominator;

    if(integer == 0 && frational == 0) cout << 0 << endl;
    else if(integer == 0 && frational != 0) cout << frational << '/' << ans.denominator << endl;
    else if(integer != 0 && frational == 0) cout << integer << endl;
    else cout << integer << ' ' << frational << '/' << ans.denominator << endl;

    return 0;
}

在这里插入图片描述

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-08-23 16:27:24  更:2021-08-23 16:28:31 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年12日历 -2024/12/27 4:38:03-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码
数据统计