Given
N
N
N rational numbers in the form numerator/denominator , you are supposed to calculate their sum.
Input Specification:
Each input file contains one test case. Each case starts with a positive integer
N
(
≤
100
)
N (≤100)
N(≤100), followed in the next line
N
N
N rational numbers a1/b1 a2/b2 ... where all the numerators and denominators are in the range of long int. If there is a negative number, then the sign must appear in front of the numerator.
Output Specification:
For each test case, output the sum in the simplest form integer numerator/denominator where integer is the integer part of the sum, numerator < denominator , and the numerator and the denominator have no common factor. You must output only the fractional part if the integer part is 0.
Sample Input 1:
5
2/5 4/15 1/30 -2/60 8/3
Sample Output 1:
3 1/3
Sample Input 2:
2
4/3 2/3
Sample Output 2:
2
Sample Input 3:
3
1/3 -1/6 1/8
Sample Output 3:
7/24
Caution:
注意【数据溢出】以及【求最大公约数】问题。
Solution:
#include <iostream>
#include <vector>
#include <cmath>
using namespace std;
long long gcd(long long a, long long b){
if(a < b) swap(a, b);
if(a % b == 0) return b;
else return gcd(b, a % b);
}
struct Num{
long long numerator;
long long denominator;
Num(long long n, long long d){
numerator = n;
denominator = d;
if(n == 0) return;
long long pos = gcd(abs(numerator), denominator);
numerator /= pos;
denominator /= pos;
}
~Num(){}
};
Num add(Num &a, Num &b){
long long numerator = a.numerator * b.denominator + b.numerator * a.denominator;
long long denomiator = a.denominator * b.denominator;
Num ans(numerator, denomiator);
return ans;
}
int main(){
int n;
scanf("%d", &n);
Num ans(0, 1);
for(int i = 0; i < n; ++i){
int numerator, denominator;
scanf("%d/%d", &numerator, &denominator);
Num tmp((long long)numerator, (long long)denominator);
ans = add(ans, tmp);
}
long long integer, frational;
integer = ans.numerator / ans.denominator;
frational = ans.numerator % ans.denominator;
if(integer == 0 && frational == 0) cout << 0 << endl;
else if(integer == 0 && frational != 0) cout << frational << '/' << ans.denominator << endl;
else if(integer != 0 && frational == 0) cout << integer << endl;
else cout << integer << ' ' << frational << '/' << ans.denominator << endl;
return 0;
}
|