IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PTA甲级 1113 Integer Set Partition (C++) -> 正文阅读

[C++知识库]PTA甲级 1113 Integer Set Partition (C++)

Given a set of N ( > 1 ) N (>1) N(>1) positive integers, you are supposed to partition them into two disjoint sets A 1 A_1 A1? and A 2 A_2 A2? of n 1 n_1 n1? and n 2 n_2 n2? numbers, respectively. Let S 1 S_1 S1? and S 2 S_2 S2? denote the sums of all the numbers in A 1 A_1 A1? and A 2 A_2 A2?, respectively. You are supposed to make the partition so that ∣ n 1 ? n 2 ∣ ∣n_1?n_2∣ n1??n2? is minimized first, and then ∣ S 1 ? S 2 ∣ ∣S_1 ?S_2∣ S1??S2? is maximized.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N ( 2 ≤ N ≤ 1 0 5 ) N (2≤N≤10^5) N(2N105), and then N N N positive integers follow in the next line, separated by spaces. It is guaranteed that all the integers and their sum are less than 2 31 2^{31} 231.

Output Specification:

For each case, print in a line two numbers: ∣ n 1 ? n 2 ∣ ∣n_1?n_2∣ n1??n2? and ∣ S 1 ? S 2 ∣ ∣S_1?S_2∣ S1??S2?, separated by exactly one space.

Sample Input 1:

10
23 8 10 99 46 2333 46 1 666 555

Sample Output 1:

0 3611

Sample Input 2:

13
110 79 218 69 3721 100 29 135 2 6 13 5188 85

Sample Output 2:

1 9359

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-25 22:43:48
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main(){
    int n;
    cin >> n;

    vector<int> nums(n);
    for(int i = 0; i < n; ++i) cin >> nums[i];

    sort(nums.begin(), nums.end());

    int s1 = 0, s2 = 0;

    for(int i = 0; i < n; ++i){
        if(i < n / 2) s1 += nums[i];
        else s2 += nums[i];
    }

    printf("%d %d\n", n % 2, s2 - s1);

    return 0;
}

在这里插入图片描述

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-08-26 11:56:22  更:2021-08-26 11:56:28 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/23 17:05:25-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码