试题编号: 201409-3 试题名称: 字符串匹配 时间限制: 1.0s 内存限制: 256.0MB 问题描述:
问题描述 给出一个字符串和多行文字,在这些文字中找到字符串出现的那些行。你的程序还需支持大小写敏感选项:当选项打开时,表示同一个字母的大写和小写看作不同的字符;当选项关闭时,表示同一个字母的大写和小写看作相同的字符。 输入格式 输入的第一行包含一个字符串S,由大小写英文字母组成。 第二行包含一个数字,表示大小写敏感的选项,当数字为0时表示大小写不敏感,当数字为1时表示大小写敏感。 第三行包含一个整数n,表示给出的文字的行数。 接下来n行,每行包含一个字符串,字符串由大小写英文字母组成,不含空格和其他字符。 输出格式 输出多行,每行包含一个字符串,按出现的顺序依次给出那些包含了字符串S的行。 样例输入 Hello 1 5 HelloWorld HiHiHelloHiHi GrepIsAGreatTool HELLO HELLOisNOTHello 样例输出 HelloWorld HiHiHelloHiHi HELLOisNOTHello 样例说明 在上面的样例中,第四个字符串虽然也是Hello,但是大小写不正确。如果将输入的第二行改为0,则第四个字符串应该输出。 评测用例规模与约定 1<=n<=100,每个字符串的长度不超过100。
问题链接:CCF201409-3 字符串匹配 问题简述:(略) 问题分析: 重写解题博客以及程序代码(参见参考链接),解题代码更加简洁,增加正则表达式题解等。 方法一:用C语言库函数来解决 C语言库函数strlwr()实现了字符串匹配的功能,其他处理也用函数实现,用函数strlwr()实现大写转小写,用函数strcpy()实现字符串复制。 需要说明的是,程序第21行for语句用了C++的语法,编译程序可以通过。 方法二:用C++的string类来解决 string类有方法find()实现了字符串匹配的功能。 方法三:用KMP算法来解决 这种做法需要自己写KMP算法实现程序。 方法四:用C++的正则表达式来解决 这里用C++的正则表达式来实现,似乎也可以用C的正则表达式来实现。 方法五:用Python的正则表达式来解决 这个似乎更加简单并且易于实现。 方法六:用Java的正则表达式来解决 Java的正则表达式包是regex。
程序说明:(略) 参考链接: CCF201409-3 字符串匹配(100分) 题记:(略)
100分的C语言程序(方法一)如下:
#include <stdio.h>
#include <string.h>
#define N 100 + 1
char key[N], s[N], lowers[N];
int main()
{
int option, n;
scanf("%s%d%d", key, &option, &n);
if (option == 0)
strlwr(key);
for (int i = 1; i <= n; i++) {
scanf("%s", s);
if (option == 0) {
strcpy(lowers, s);
strlwr(lowers);
if (strstr(lowers, key)) printf("%s\n", s);
} else
if (strstr(s, key)) printf("%s\n", s);
}
return 0;
}
100分的C++语言程序(方法二)如下:
#include <iostream>
#include <cctype>
#include <string>
using namespace std;
int main()
{
string key, s, st;
int option, n;
cin >> key >> option >> n;
if (option == 0)
for (int i=0; key[i]; i++)
if(isupper(key[i])) key[i] = tolower(key[i]);
for (int i=1; i<=n; i++) {
cin >> s;
if (option == 0) {
st = s;
for (int i=0; st[i]; i++)
if(isupper(st[i])) st[i] = tolower(st[i]);
int pos = st.find(key);
if (pos >= 0) cout << s << endl;
} else {
int pos = s.find(key);
if (pos >= 0) cout << s << endl;
}
}
return 0;
}
100分的C++语言程序(方法三)如下:
#include <iostream>
#include <cstring>
using namespace std;
void getnext(int next[], char t[])
{
int i=0, j=-1;
next[0] = -1;
while (t[i] != '\0')
if (j == -1 || t[i] == t[j]) next[++i] = ++j;
else j = next[j];
}
int kmp(int next[], char s[], char t[])
{
int i=0, j=0, len1=strlen(s), len2=strlen(t);
while (i < len1 && j < len2)
if (j == -1 || s[i] == t[j]) ++i, ++j;
else j = next[j];
if (j >= len2) return i-len2+1;
else return -1;
}
const int N = 100 + 1;
int next2[N];
char s[N], s2[N], key[N+1];
int main()
{
int option, m;
cin >> key >> option;
if(option == 0)
for(int i=0; key[i]; i++)
key[i] = tolower(key[i]);
getnext(next2, key);
cin >> m;
while (m--) {
cin >> s;
strcpy(s2, s);
if (option == 0)
for(int i=0; s2[i]; i++)
s2[i] = tolower(s2[i]);
if (kmp(next2, s2, key) != -1)
cout << s << endl;
}
return 0;
}
100分的C语言程序(方法四)如下:
#include <iostream>
#include <regex>
using namespace std;
int main()
{
string key, s;
int option, n;
cin >> key >> option >> n;
regex rule;
if (option == 0)
rule = regex("[a-zA-Z]*" + key + "[a-zA-Z]*", regex::icase);
else
rule = regex("[a-zA-Z]*" + key +"[a-zA-Z]*");
while (n--) {
cin >> s;
if (regex_match(s, rule)) cout << s << endl;
}
return 0;
}
100分的Python语言程序(方法五)如下:
import re
k = input()
option = int(input())
n = int(input())
s = []
for i in range(n):
s = input()
if option == 1:
if re.search(k, s) != None:
print(s)
else:
if re.search(k, s, re.IGNORECASE) != None:
print(s)
100分的Java语言程序(方法六)如下:
import java.util.Scanner;
import java.util.regex.*;
public class Main {
public static void main(String args[]){
Scanner input = new Scanner(System.in);
String key = input.next();
int option = input.nextInt();
int n = input.nextInt();
String pk = "[a-zA-Z]*" + key + "[a-zA-Z]*";
Pattern p;
if (option == 0)
p = Pattern.compile(pk, Pattern.CASE_INSENSITIVE);
else
p = Pattern.compile(pk);
for (int i=1; i<=n; i++) {
String s = input.next();
Matcher m = p.matcher(s);
if (m.find())
System.out.println(s);
}
}
}
|