IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PTA甲级 1125 Chain the Ropes (C++) -> 正文阅读

[C++知识库]PTA甲级 1125 Chain the Ropes (C++)

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.
在这里插入图片描述
Your job is to make the longest possible rope out of N N N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( 2 ≤ N ≤ 1 0 4 ) N (2≤N≤10^4) N(2N104). Then N N N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 1 0 4 10^4 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

Caution:

比较有意思的一道小题目,其实想通了之后代码很简单,首先两段绳子,合成一次后变成一段,绳子段数减一,所以n段绳子要想最终变成 1 段绳子,一定要合成n-1次,而每段最初的绳子每被用来合成一次,他在最终绳子中的贡献就少一半,所以我们要尽量不浪费最初的资源,就要每次都让最短的两根绳子来合成(这样的话最长的绳子一定是在最后被用来合成,他在最终的绳子中的贡献就最大)。

代码就是先排序,然后i1n-1遍历数组,每次更新nums[i](nums[i] + nums[i - 1]) / 2,表示用这两根绳子来合成新绳子(为什么合成新绳子后不用再排序呢?因为新合成的绳子的长度是原来两根绳子的一半,所以新的nums[i]一定小于旧的nums[i],自然一定小于nums[i + 1]

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-27 22:20:44
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;

int main(){
    int n;
    scanf("%d", &n);

    vector<double> nums(n);

    for(int i = 0; i < n; ++i) cin >> nums[i];
    sort(nums.begin(), nums.end());

    for(int i = 1; i < n; ++i) nums[i] = (nums[i] + nums[i - 1]) / 2;

    printf("%d\n", (int)nums[n - 1]);
    
    return 0;
}

在这里插入图片描述

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-08-28 08:51:02  更:2021-08-28 08:51:47 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/23 17:21:02-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码