IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PTA甲级 1130 Infix Expression (C++) -> 正文阅读

[C++知识库]PTA甲级 1130 Infix Expression (C++)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 20 ) N (≤ 20) N(20) which is the total number of nodes in the syntax tree. Then N N N lines follow, each gives the information of a node (the i i i-th line corresponds to the i i i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node’s left and right children, respectively. The nodes are indexed from 1 to N N N. The NULL link is represented by ? 1 ?1 ?1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.
在这里插入图片描述

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

Caution:

测试点 2 不过是因为没考虑就一个根节点的情况(我一开始的代码是默认到最后去掉头尾的括号,但是如果只有一个根节点的话我的代码是不会在头尾加上括号的)。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-28 18:50:17
// All rights reserved.

#include <iostream>
#include <vector>
#include <unordered_map>

using namespace std;

string ans = "";
vector<string> input;
vector<pair<int, int>> children;

struct Node{
    int id;
    string content;
    Node *left;
    Node *right;

    Node(int k, string s){
        id = k;
        content = s;
        left = NULL;
        right = NULL;
    }

    ~Node(){}
};

void findChildren(Node *r){
    if(r == NULL) return;

    int left = children[r -> id].first;
    int right = children[r -> id].second;

    if(left != -1) r -> left = new Node(left, input[left]);
    if(right != -1) r -> right = new Node(right, input[right]);

    findChildren(r -> left);
    findChildren(r -> right);
}

void inTraverse(Node *r){
    if(r == NULL) return;

    if(r -> left != NULL || r -> right != NULL) ans += "(";
        
    if(r -> left != NULL) inTraverse(r -> left);
    ans += r -> content;
    if(r -> right != NULL) inTraverse(r -> right);

    if(r -> left != NULL || r -> right != NULL) ans += ")";
    
}

int main(){
    
    int n;
    cin >> n;
    
    input.resize(n + 1);
    children.resize(n + 1);
    unordered_map<int, bool> flags;
    
    string tmp;
    int left, right;
    for(int i = 1; i <= n; ++i){
        cin >> tmp >> left >> right;

        input[i] = tmp;
        children[i].first = left;
        children[i].second = right;
        flags[left] = flags[right] = true;
    }

    int r = 0;
    for(int i = 1; i <= n; ++i){
        if(flags[i] == false){
            r = i;
            break;
        }
    }
    
    Node *root = new Node(r, input[r]);

    findChildren(root);

    inTraverse(root);
    
    if(ans[0] == '(') printf("%s\n", ans.substr(1, ans.length() - 2).c_str());
    else printf("%s\n", ans.c_str());

    return 0;
}

在这里插入图片描述

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-08-29 08:54:26  更:2021-08-29 08:55:48 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/23 17:06:53-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码