IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PTA甲级 1141 PAT Ranking of Institutions (C++) -> 正文阅读

[C++知识库]PTA甲级 1141 PAT Ranking of Institutions (C++)

After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 1 0 5 ) N (≤10^5) N(105), which is the number of testees. Then N N N lines follow, each gives the information of a testee in the following format:

ID Score School

where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level, A the advanced level and T the top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

Output Specification:

For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format:

Rank School TWS Ns

where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution.

The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

Sample Input:

10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

Sample Output:

5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-29 22:06:54
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>
#include <unordered_map>

using namespace std;

struct School{
    string name;
    int ns;
    int  sumB, sumA, sumT;
    int tws;

    School(string n){
        name = n;
        ns = 0;
        sumB = sumA = sumT = 0;
        tws = -1;
    }
    ~School(){}
};

bool cmp(School &a, School &b){
    if(a.tws != b.tws) return a.tws > b.tws;
    if(a.ns != b.ns) return a.ns < b.ns;
    return a.name < b.name;
}

int main(){
    int n;
    scanf("%d", &n);
    
    unordered_map<string, bool> hasAppeared;
    unordered_map<string, int> position;
    vector<School> schools;

    string id, school;
    int score;
    for(int i = 0; i < n; ++i){
        cin >> id >> score >> school;
        
        transform(school.begin(), school.end(), school.begin(), ::tolower);

        if(hasAppeared[school] == false){
            hasAppeared[school] = true;
            schools.emplace_back(school);

            int pos = schools.size() - 1;
            position[school] = pos;

            schools[pos].ns++;
            if(id[0] == 'B') schools[pos].sumB += score;
            else if(id[0] == 'A') schools[pos].sumA += score;
            else schools[pos].sumT += score;
        }
        else{
            int pos = position[school];

            schools[pos].ns++;
            if(id[0] == 'B') schools[pos].sumB += score;
            else if(id[0] == 'A') schools[pos].sumA += score;
            else schools[pos].sumT += score;
        }
    }
    for(int i = 0; i < schools.size(); ++i) 
        schools[i].tws = (int)(schools[i].sumB / 1.5 + schools[i].sumA + schools[i].sumT * 1.5);

    sort(schools.begin(), schools.end(), cmp);

    printf("%d\n", (int)schools.size());
    int rank = 1;
    for(int i = 0; i < schools.size(); ++i){
        if(i == 0) printf("1 %s %d %d\n", schools[i].name.c_str(), schools[i].tws, schools[i].ns);
        else{
            if(schools[i].tws != schools[i - 1].tws) rank = i + 1;
            printf("%d %s %d %d\n", rank, schools[i].name.c_str(), schools[i].tws, schools[i].ns);
        }
    }

    return 0;
}

在这里插入图片描述

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-08-30 11:49:20  更:2021-08-30 11:50:40 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2025年1日历 -2025/1/12 21:53:30-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码