IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PTA甲级 1152 Google Recruitment (C++) -> 正文阅读

[C++知识库]PTA甲级 1152 Google Recruitment (C++)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e e e. The person who could find this prime number could go to the next step in Google’s hiring process by visiting this website.
在这里插入图片描述
The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921… where the 10 digits in bold are the answer to Google’s question.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L ( ≤ 1 , 000 ) L (≤ 1,000) L(1,000) and K ( < 10 ) K (< 10) K(<10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L L L-digit number N N N is given in the next line.

Output Specification:

For each test case, print in a line the first K K K-digit prime in consecutive digits of N N N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K K K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-30 21:45:46
// All rights reserved.

#include <iostream>
#include <vector>
#include <cmath>

using namespace std;

bool isPrime(int a){
    if(a <= 1) return false;
    if(a <= 3) return true;

    for(int i = 2; i <= sqrt(a); ++i){
        if(a % i == 0) return false;
    } 
    return true;
}

int main(){
    int l, n;
    scanf("%d %d", &l, &n);
    string s;
    cin >> s;

    for(int i = 0; i < l + 1 - n; ++i){
        string tmp = s.substr(i, n);

        int t = stoi(tmp);
        if(isPrime(t)){
            printf("%s\n", tmp.c_str());
            return 0;
        }
    }

    printf("404\n");

    return 0;
}

在这里插入图片描述

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-08-31 15:16:03  更:2021-08-31 15:17:53 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/23 17:19:55-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码