IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> PTA甲级 1021 Deepest Root (C++) -> 正文阅读

[C++知识库]PTA甲级 1021 Deepest Root (C++)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N ( ≤ 1 0 4 ) N (≤10^4) N(104) which is the number of nodes, and hence the nodes are numbered from 1 to N N N. Then N ? 1 N?1 N?1 lines follow, each describes an edge by given the two adjacent nodes’ numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print Error: K components where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

Caution:

求一个图中最深的根:先从一个结点dfs后保留最高高度拥有的结点们,然后从这些结点中的其中任意一个开始dfs得到最高高度的结点们,这两个结点集合的并集就是所求

来源:https://blog.csdn.net/liuchuo/article/details/52294178

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-09-03 21:11:45
// All rights reserved.

#include <iostream>
#include <vector>
#include <algorithm>
#include <queue>
#include <unordered_map>

using namespace std;

int n;
int edges[10010][10010];
vector<int> ans;

int computeComponent(){
    int cnt = 0;
    int ans = 0;
    unordered_map<int, bool> visited;

    while(cnt < n){
        queue<int> q;
        int pos = 1;

        while(visited[pos] == true) pos++;

        visited[pos] = true;
        q.push(pos);
        while(!q.empty()){
            int size = q.size();
            cnt += size;

            for(int i = 0; i < size; ++i){
                int tmp = q.front();
                q.pop();

                for(int j = 1; j <= n; ++j){
                    if(edges[tmp][j] != 0 && !visited[j]){
                        q.push(j);
                        visited[j] = true;
                    }
                }
            }
        }

        ans++;
    }

    return ans;
}

void dfs(int idx){
    unordered_map<int, bool> visited;
    queue<int> q;

    visited[idx] = true;
    q.push(idx);
    int cnt = 0;

    while(cnt < n){
        int size = q.size();
        cnt += size;

        for(int i = 0; i < size; ++i){
            int tmp = q.front();
            q.pop();
            if(cnt == n){
                ans.push_back(tmp);
                continue;
            }

            for(int j = 1; j <= n; ++j){
                if(edges[tmp][j] != 0 && !visited[j]){
                    q.push(j);
                    visited[j] = true;
                }
            }
        }
    }

    return ;
}

int main(){
    
    scanf("%d", &n);

    for(int i = 0; i < n - 1; ++i){
        int a, b;
        scanf("%d %d", &a, &b);

        edges[a][b] = 1;
        edges[b][a] = 1;
    }

    int component = computeComponent();
    if(component > 1) printf("Error: %d components\n", component);
    else{
        dfs(1);
        if(ans[0] != 1) dfs(ans[0]);
        else if(ans.size() > 1) dfs(ans[1]);

        sort(ans.begin(), ans.end());
        for(int i = 0; i < ans.size(); ++i){
            if(i > 0 && ans[i] == ans[i - 1]) continue;
            printf("%d\n", ans[i]);
        }
    }


    return 0;
}

在这里插入图片描述

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-09-04 17:19:43  更:2021-09-04 17:20:26 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/23 20:43:31-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码