1076 Forwards on Weibo (30 分)
Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.
Input Specification: Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:
M[i] user_list[i],where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.
Then finally a positive K is given, followed by K UserID’s for query.
Output Specification: For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.
Sample Input: 7 3 3 2 3 4 0 2 5 6 2 3 1 2 3 4 1 4 1 5 2 2 6 Sample Output: 4 5 题目大意:微博可以关注他人,给出每个人关注的人,给出可以转发的层数,问最多可以有多少人转发。 分析:带层数的广度优先,queue中变量使用node型,在其中记录layer,用inq判断是否入过队,关注他人——图中边由被关注者指向关注者。
#include<iostream>
#include<vector>
#include<queue>
using namespace std;
const int maxn = 1010;
struct node {
int v, layer;
};
int n, m, l, k;
bool inq[maxn] = { false };
vector<vector<int> > G;
int BFS(node tnode) {
fill(inq, inq + maxn, false);
int cnt = 0;
queue<node> q;
q.push(tnode);
inq[tnode.v] = true;
while (!q.empty()) {
node top = q.front();
int topv = top.v;
q.pop();
for (int i = 0;i < G[topv].size();++i) {
if (inq[G[topv][i]] == false && top.layer < l) {
node next = { G[topv][i],top.layer + 1 };
q.push(next);
inq[G[topv][i]] = true;
++cnt;
}
}
}
return cnt;
}
int main() {
scanf("%d %d", &n, &l);
G.resize(n + 1);
for (int i = 1;i <= n;++i) {
scanf("%d", &m);
for (int j = 0;j < m;++j) {
int u;
scanf("%d", &u);
G[u].push_back(i);
}
}
scanf("%d", &k);
for (int i = 0;i < k;++i) {
int uid;
scanf("%d", &uid);
node tnode = { uid,0 };
printf("%d\n", BFS(tnode));
}
return 0;
}
|