IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> 【中国大学MOOC-陈越、何钦铭-数据结构-起步能力自测题】自测4 Have Fun with Numbers -> 正文阅读

[C++知识库]【中国大学MOOC-陈越、何钦铭-数据结构-起步能力自测题】自测4 Have Fun with Numbers

Question:
Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:
Each input contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.

Sample Input:

1234567899
结尾无空行

Sample Output:

Yes
2469135798
结尾无空行

代码

#define _CRT_SECURE_NO_WARNINGS 1 
#include<stdio.h>
#include <string.h>
int judge(int arr1[],int arr2[],int x)
{
	for (int i = 0; i < x; i++)
	{
		if (arr1[i] != 0 && arr2[0] != 0)
		{
			return 0;
		}
	}
	return 1;
}
int main()
{
	char temp1[22];//方便存入

	scanf("%s", temp1);
	int sz = strlen(temp1);//计算位数
	int a[50] = { 0 };
	int b[51] = { 0 };
	int dit[10] = { 0,0,0,0,0,0,0,0,0,0 };

	for (int i = 0; i < sz; i++)
	{
		a[i] = temp1[i] - '0';	//temp中的数字存入整型数组
		dit[a[i]]++;//记录0-9数字分别的个数
	}
	int carry_bit = 0;
	for (int i = sz - 1; i >= 0; i--)
	{
		b[i+1] =carry_bit;
		int amass= a[i] * 2 ;
		if (amass >=10)
		{
			b[i+1] = amass % 10+b[i+1];
			carry_bit = (amass -b[i+1]+ carry_bit)/10;
			if (b[i+1] >= 10)
			{
				carry_bit++;
				b[i+1] = b[i+1] - 10;
			}

		}
		else
		{
			b[i+1] = amass+b[i+1];
			carry_bit = 0;
		}

	}
	b[0] = carry_bit;
	for (int i = 0; i < sz; i++)
	{
		dit[b[i+1]]--;
	}

	if (judge(dit,b,sz)== 0)
	{
		printf("No\n");
		for (int i = 0; i < sz + 1; i++)
		{
			printf("%d", b[i]);
		}
	}
	else
	{
		printf("Yes\n");
		for (int i = 1; i < sz + 1; i++)
		{
			printf("%d", b[i]);
		}
		
	}

	return 0;
}
  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-09-10 10:40:43  更:2021-09-10 10:41:59 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/23 19:59:40-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码