在猜数列游戏1的基础上,设置一个数组用来存放6个数列的第2到第4个数,在用户要求猜测新数列的情况下,循环显示各数列的前两个数,要求用户猜测第3个数。 6个数列3个组成的数组为:{1,2,3,3,4,7,2,5,12,3,6,10,4,9,16,5,12,22}
输入格式:
根据要求输入整数数值为字符Y或N
输出格式:
各提示信息与猜数列游戏1一致。
输入样例:
在这里给出一组输入。例如:
3
Y
7
Y
12
Y
10
Y
16
Y
22
Y
5
Y
3
N
输出样例:
在这里给出相应的输出。例如:
The first 2 value is 1,2.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 3,4.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 2,5.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 3,6.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 4,9.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 5,12.What is the next value?
Want to try another sequence?(Y/N)
The first 2 value is 1,2.What is the next value?
Nice guess but not quite it.
Do you want to guess again?
Want to try another sequence?(Y/N)
num_of_rights:7 num_of_tries:8
代码实现(C++)
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
int a1=3,a2=5,i=0,num,sum_t=0,sum_Y=0;
int a[18]={1,2,3,3,4,7,2,5,12,3,6,10,4,9,16,5,12,22};
int count=0;
char ch,ch2;
bool go1=true,go2=true;
while(1)
{
if(i<1)
cout << "The first 2 value is " << a[count] << ',' << a[count+1] << ".What is the next value?" << endl;
i++;
if(i<=100&&i>=1)
cin >> num;
while(1)
{
if(num!=a[count+2]&&i==1)
{
printf("Nice guess but not quite it.\n");
sum_t++;
}
if(num!=a[count+2]&&i==2)
{
printf("Wrong a second time.\n");
sum_t++;
}
if(num!=a[count+2]&&i==3)
{
printf("This is harder than it looks.\n");
sum_t++;
}
if(num!=a[count+2]&&i==4)
{
sum_t++;
printf("It must be getting pretty frustrating by now!\n");
}
if(num!=a[count+2])
{
printf("Do you want to guess again?\n");
cin >> ch2;
if(ch2=='Y')
{
break;
}
}
if(num == a[count+2]||ch2=='N')
{
i=0;
if(num==a[count+2])
{
sum_Y++;
sum_t++;
}
printf("Want to try another sequence?(Y/N)\n");
if(count<15)
{
count+=3;
}
else count=0;
cin >> ch;
if(ch == 'Y')
break;
else
{
printf("num_of_rights:%d num_of_tries:%d",sum_Y,sum_t);
exit(0);
}
}
}
}
return 0;
}
|