IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> [C语言] PTA 7-43 Shuffling Machine |2021-10-27 -> 正文阅读

[C++知识库][C语言] PTA 7-43 Shuffling Machine |2021-10-27

Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid "inside jobs" where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ?automatic shuffling machines. Your task is to simulate a shuffling machine.

The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:

S1, S2, ..., S13, 
H1, H2, ..., H13, 
C1, C2, ..., C13, 
D1, D2, ..., D13, 
J1, J2

where "S" stands for "Spade", "H" for "Heart", "C" for "Club", "D" for "Diamond", and "J" for "Joker". A given order is a permutation of distinct integers in [1, 54]. If the number at the?i-th position is?j, it means to move the card from position?i?to position?j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer?K?(≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.

Sample Input:

2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47

结尾无空行

Sample Output:

S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5

结尾无空行

题目大意,现有54张扑克牌(四种花色各13张加两张大小王),给出每张牌的序号,要求按给定的序号重新排列,此为“一次打乱”。输入时还会给出一个打乱次数,即重复按照刚才给出的序号进行排序的步骤。

首先要存放排序的次数,牌的标号以及序号。

C语言没有字符串类型的数组,搞个指针数组char *number[54]用来存放“S1”这种字符串。由于可能要多次排序,就再创建一个用于存放排好序的数组char *tmp[54]。用int a[54]存放序号

接着是排序

在一个for循环里把序号读入数组a,再用一个双重循环:外层表示一共需要几次排序,内层表示一次排序:使tmp[a[i]]=number[i]。

最后输出n次排序后的结果(结尾无空格)

一个for循环。当i=53时不输出空格

代码如下:

#include<stdio.h>
int main(){
	
	int n;
	char *card[56]={"S1","S2","S3","S4","S5","S6","S7","S8","S9","S10","S11","S12","S13",
					"H1","H2","H3","H4","H5","H6","H7","H8","H9","H10","H11","H12","H13",
					"C1","C2","C3","C4","C5","C6","C7","C8","C9","C10","C11","C12","C13",
					"D1","D2","D3","D4","D5","D6","D7","D8","D9","D10","D11","D12","D13",
					"J1","J2"};
	scanf("%d",&n);
	
	char *tmp[56]={"",};
	int i,j;
	int a[56];//存放序号的数组 
	
	for(i=0;i<54;i++){
		scanf("%d",&a[i]);
	}
	
	int order;
	for(i=0;i<n;i++){
		
		for(j=0;j<54;j++){
			order=a[j]-1;
			tmp[order]=card[j];//用tmp存放排序过后的卡组 
		//调试用的 printf("%s %d\n",tmp[order],order); 
		}
		
		for(j=0;j<54;j++){
			//order=a[j]-1;这句没用,但是当时这里出了错了
			card[j]=tmp[j];//把card数组也变成排序后的样子以便继续排序 
		}
	}
	
	//输出排序后的卡组 
	for(j=0;j<54;j++){
		if(j<53){
			printf("%s ",tmp[j]);
		} else{
			printf("%s",tmp[j]);
		}
	}
	
	return 0;
} 

A了A了,没出问题

中途出现过的问题:

①头一回用指针。数组tmp未初始化时不能实现tmp[order]=card[j],具体为啥没搞懂,有没有大佬给讲讲?

②排序好后把tmp数组复制给card的过程中,写成了card[j]=tmp[order]导致赋值了个寂寞(这俩本来就相等)

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-10-28 12:13:13  更:2021-10-28 12:13:55 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/24 5:35:06-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码