IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> c++ 计算图形的面积 -> 正文阅读

[C++知识库]c++ 计算图形的面积

Problem Description
定义一个图形基类Shape,在此基础上派生出长方形Rectangle和圆Circle,
使用Rectangle类派生正方形类Square。计算图形的面积。
请完善下面的程序。
//你的代码将被嵌在这里
int main()
{
Shape* ps;
Rectangle* pr;

double r;
cin >> r;
ps = new Circle(r);
cout << "The area of the Circle is " << ps->getArea() << endl;
delete ps;

double l,w;
cin >> l>>w;
ps = new Rectangle(l, w);
cout << "The area of the Rectagle is " << ps->getArea() << endl;
delete ps;

double s1;
cin >> s1;
ps = new Square(s1);
cout << "The area of the Square is " << ps->getArea() << endl;
delete ps;

double s2;
cin >> s2;
pr = new Square(s2);
cout << "The area of the Square is " << pr->getArea() << endl;
delete pr;

return 0;

}

Input Description
第1个数是圆的半径
第2、3个数是长方形的长和宽
第4个数是一个正方形的边长
第5个数是另一个正方形的边长
Sample Input
1 2 3 4 5
Sample Output
The area of the Circle is 3.14
The area of the Rectagle is 6
The area of the Square is 16
The area of the Square is 25

#include <iostream>
using namespace std;
constexpr double PI = 3.14;

class Shape
{
public:
    Shape(){}//基类要有构造函数
    virtual double getArea() = 0;//纯虚函数
};

class Rectangle:public Shape
{
public:
    double x, y;
    Rectangle(double a, double b)
    {
        x = a;
        y = b;
    }
    double getArea()
    {
        return x * y;
    }
    Rectangle(){}
};


class Circle :public Shape
{
public:
    double R;
    Circle(double a)
    {
        R = a;
    }
    double getArea()
    {
        return PI * R * R;
    }
    Circle(){}
};

class Square :public Rectangle
{
public:
    double k;
    Square(double a)
    {
        k = a;
    }
    double getArea()
    {
        return k * k;
    }
    Square(){}
};

int main()
{
    Shape* ps;
    Rectangle* pr;

    double r;//圆的半径
    cin >> r;
    ps = new Circle(r);//堆区创建一块新的内存,图形基类指针维护
    cout << "The area of the Circle is " << ps->getArea() << endl;//输出圆的面积
    delete ps;//手动释放堆区新建空间

    double l, w;//长方形长,宽
    cin >> l >> w;
    ps = new Rectangle(l, w);
    cout << "The area of the Rectagle is " << ps->getArea() << endl;
    delete ps;

    double s1;
    cin >> s1;
    ps = new Square(s1);
    cout << "The area of the Square is " << ps->getArea() << endl;
    delete ps;

    double s2;
    cin >> s2;
    pr = new Square(s2);//长方形类指针指向
    cout << "The area of the Square is " << pr->getArea() << endl;
    delete pr;

    return 0;
}

#include<iostream>
#include<string.h>
#include<string>
#include<iomanip>
#include<math.h>
using namespace std;
class Shape
{
public:
    Shape(){}
    virtual double getArea() = 0;
};
class Rectangle :public Shape
{
public:
    double c, k;
    Rectangle(double a=0, double b=0)
    {
        c = a; k = b;
    }
    virtual double getArea()
    {
        return c * k ;
    }
};
class Circle :public Shape
{
public:
    double r;
    Circle(double a=0.0)
    {
        r = a;
    }
    virtual double getArea()
    {
        return 3.14 * r * r;
    }
};
class Square :public Rectangle
{
public:
    double bc;
    Square(double a)
    {
        bc = a;
    }
    virtual double getArea()
    {
        return bc * bc;
    }
};
  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2021-12-08 13:38:17  更:2021-12-08 13:40:29 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/24 11:26:23-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码