IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> 1031 Hello World for u -> 正文阅读

[C++知识库]1031 Hello World for u

Given any string of?N?(≥5) characters, you are asked to form the characters into the shape of?U. For example,?helloworld?can be printed as:

h  d
e  l
l  r
lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with?n1??characters, then left to right along the bottom line with?n2??characters, and finally bottom-up along the vertical line with?n3??characters. And more, we would like?U?to be as squared as possible -- that is, it must be satisfied that?n1?=n3?=max?{?k?|?k≤n2??for all?3≤n2?≤N?} with?n1?+n2?+n3??2=N.

Input Specification:

Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:

For each test case, print the input string in the shape of U as specified in the description.

Sample Input:

helloworld!

Sample Output:

h   !
e   d
l   l
lowor

编译软件:visual studio

编译语言:c语言

参考代码:

#include<cstdio>
#include<cstring>

int main()
{
?? ?char str[100], ans[40][40];
?? ?gets_s(str, 100);
?? ?int N = strlen(str);
?? ?int n1 = (N + 2) / 3, n3 = n1, n2 = N + 2 - n1 - n3;
?? ?for (int i = 1; i <= n1; i++)
?? ?{
?? ??? ?for (int j = 1; j <= n2; j++)
?? ??? ?{
?? ??? ??? ?ans[i][j] = ' ';
?? ??? ?}
?? ?}
?? ?int pos = 0;
?? ?for (int i = 1; i <= n1; i++)
?? ?{
?? ??? ?ans[i][1] = str[pos++];
?? ?}
?? ?for (int j = 2; j <= n2; j++)
?? ?{
?? ??? ?ans[n1][j] = str[pos++];
?? ?}
?? ?for (int i = n3 - 1; i >= 1; i--)
?? ?{
?? ??? ?ans[i][n2] = str[pos++];
?? ?}
?? ?for (int i = 1; i <= n1; i++)
?? ?{
?? ??? ?for (int j = 1; j <= n2; j++)
?? ??? ?{
?? ??? ??? ?printf("%c", ans[i][j]);
?? ??? ?}
?? ??? ?printf("\n");
?? ?}
?? ?return 0;
}

注:在pat中gets_s(str,100)始终编译不出来,不知道是为什么,希望有懂的大佬能解答一下,我自己的处理方法就是将gets_s(str,100)改成了scanf("%s",str)

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2022-01-04 13:14:05  更:2022-01-04 13:15:39 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/24 10:25:16-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码