IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> 7-12 实验2_6_幂计算 (100 分) -> 正文阅读

[C++知识库]7-12 实验2_6_幂计算 (100 分)

已知两个整数x和y(x为任意整数,y为非负整数),利用循环结构计算x的y次幂并输出。假设x,y及x的y次幂不会超过int型范围。

输入格式:

只有一行,为两个用空格分隔的整数,依次代表x与y的值。

输出格式:

也只有一行,为一个整数,即x的y次幂的计算结果(测试数据中保证没有0的0次幂)。例如输出2的4次幂结果,即16。

样例">输入样例:

-7 5

输出样例:

-16807

代码如下:

#include<stdio.h>
int main()
{
    int x, y,xh=1;
	scanf("%d %d", &x, &y);
	//计算x的y次幂并输出
	for (; y > 0; y--)
		xh = xh * x;
	printf("%d", xh);
	return 0;
}

本题考查基本的for循环的应用

下面介绍C语言中的次方(幂次)的函数:

function

<cmath> <ctgmath>

pow

  • C90
  • C99
  • C++98
  • C++11
double pow (double base, double exponent);

Raise to power

Returns?base?raised to the power?exponent:

baseexponent

  • C99
  • C++98
  • C++11

Header?<tgmath.h>?provides a type-generic macro version of this function.

Parameters

base

Base value.

exponent

Exponent value.

Return Value

The result of raising?base?to the power?exponent.

If the?base?is finite?negative and the?exponent?is finite?but not an integer value, it causes a?domain error.
If both?base?and?exponent?are zero, it may also cause a?domain error?on certain implementations.
If?base?is zero and?exponent?is negative, it may cause a?domain error?or a?pole error?(or none, depending on the library implementation).
The function may also cause a?range error?if the result is too great or too small to be represented by a value of the return type.

  • C90 (C++98)
  • C99 (C++11)

If a?domain error?occurs, the global variable?errno?is set to?EDOM.
If a?pole?or?range error?occurs, the global variable?errno?is set?ERANGE.

Example

1
2
3
4
5
6
7
8
9
10
11
/* pow example */
#include <stdio.h>      /* printf */
#include <math.h>       /* pow */

int main ()
{
  printf ("7 ^ 3 = %f\n", pow (7.0, 3.0) );
  printf ("4.73 ^ 12 = %f\n", pow (4.73, 12.0) );
  printf ("32.01 ^ 1.54 = %f\n", pow (32.01, 1.54) );
  return 0;
}

?Edit & Run



Output:

7 ^ 3 = 343.000000
4.73 ^ 12 = 125410439.217423
32.01 ^ 1.54 = 208.036691

大家估计没兴趣认真看,做一个总结

1,函数名:POW? ??

double pow (double base, double exponent);
返回值为double类型

2,作用:求幂次

? pow(A,B)? ?就是A的B次方

3, 头文件:#include<math.h>

所以代码可以简化为:

#include<stdio.h>
#include<math.h>
int main()
{
	int x, y;
	scanf("%d %d", &x, &y);
	printf("%d", (int)pow(x, y));
return 0;

}

注意要强制类型转换,引用头文件!!

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2022-01-08 13:48:12  更:2022-01-08 13:48:59 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/24 11:29:31-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码