IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> A1062 Talent and Virtue (25 分)PAT甲级(C++) -> 正文阅读

[C++知识库]A1062 Talent and Virtue (25 分)PAT甲级(C++)

About 900 years ago, a Chinese philosopher Sima Guang wrote a history book in which he talked about people's talent and virtue. According to his theory, a man being outstanding in both talent and virtue must be a "sage(圣人)"; being less excellent but with one's virtue outweighs talent can be called a "nobleman(君子)"; being good in neither is a "fool man(愚人)"; yet a fool man is better than a "small man(小人)" who prefers talent than virtue.

Now given the grades of talent and virtue of a group of people, you are supposed to rank them according to Sima Guang's theory.

Input Specification:

Each input file contains one test case. Each case first gives 3 positive integers in a line:?N?(≤105), the total number of people to be ranked;?L?(≥60), the lower bound of the qualified grades -- that is, only the ones whose grades of talent and virtue are both not below this line will be ranked; and?H?(<100), the higher line of qualification -- that is, those with both grades not below this line are considered as the "sages", and will be ranked in non-increasing order according to their total grades. Those with talent grades below?H?but virtue grades not are considered as the "noblemen", and are also ranked in non-increasing order according to their total grades, but they are listed after the "sages". Those with both grades below?H, but with virtue not lower than talent are considered as the "fool men". They are ranked in the same way but after the "noblemen". The rest of people whose grades both pass the?L?line are ranked after the "fool men".

Then?N?lines follow, each gives the information of a person in the format:

ID_Number Virtue_Grade Talent_Grade

where?ID_Number?is an 8-digit number, and both grades are integers in [0, 100]. All the numbers are separated by a space.

Output Specification:

The first line of output must give?M?(≤N), the total number of people that are actually ranked. Then?M?lines follow, each gives the information of a person in the same format as the input, according to the ranking rules. If there is a tie of the total grade, they must be ranked with respect to their virtue grades in non-increasing order. If there is still a tie, then output in increasing order of their ID's.

Sample Input:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

Sample Output:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

代码如下:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
struct person
{
	int id;
	int virtue;
	int talent;
	int total;
};
vector<person>sage,noble,fool,rest;
bool cmp(const person& a, const person& b) {
	if (a.total != b.total)
		return a.total > b.total;
	else if (a.virtue != b.virtue)
		return a.virtue > b.virtue;
	else
		return a.id < b.id;	
}
int main()
{
	int n, low ,high;
	cin >> n >> low >> high;
	int ranknum = 0;//记录实际参与排名的人数
	//int id, virtue, talent;
	person per;
	//对所有人进行分类
	for (int i = 0; i < n; i++)
	{
		cin >> per.id >> per.virtue >> per.talent;
		per.total = per.virtue + per.talent;
		if (per.virtue >= high&& per.talent >= high) {
			sage.push_back(per);
			ranknum++;
		}
		else if (per.virtue >= high&& per.talent<high && per.talent>=low){
			noble.push_back(per);
			ranknum++;
		}
		else if (per.virtue>=low && per.talent>=low&&per.virtue>=per.talent){
			fool.push_back(per);
			ranknum++;
		}
		else if (per.virtue >= low && per.talent >= low){
			rest.push_back(per);
			ranknum++;
		}
	}
	cout << ranknum << endl;
	//对每一类人排序
	sort(sage.begin(),sage.end(), cmp);
	sort(noble.begin(), noble.end(), cmp);
	sort(fool.begin(), fool.end(), cmp);
	sort(rest.begin(), rest.end(), cmp);
	for (int i = 0; i < sage.size(); i++)
		cout << sage[i].id << " " <<sage[i].virtue << " " << sage[i].talent << endl;
	for (int i = 0; i < noble.size(); i++)
		cout << noble[i].id << " " << noble[i].virtue << " " << noble[i].talent << endl;
	for (int i = 0; i < fool.size(); i++)
		cout << fool[i].id << " " << fool[i].virtue << " " << fool[i].talent << endl;
	for (int i = 0; i < rest.size(); i++) {
		if (i == rest.size()-1)
			cout << rest[i].id << " " << rest[i].virtue << " " << rest[i].talent;
		else cout << rest[i].id << " " << rest[i].virtue << " " << rest[i].talent << endl;
	}
	return 0;
}

运行结果如下:

?

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2022-03-04 15:19:50  更:2022-03-04 15:22:05 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/24 5:32:36-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码