IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> 1067 Sort with Swap(0,i) -> 正文阅读

[C++知识库]1067 Sort with Swap(0,i)

Given any permutation of the numbers {0, 1, 2,...,?N?1}, it is easy to sort them in increasing order. But what if?Swap(0, *)?is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first?N?nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive?N?(≤105) followed by a permutation sequence of {0, 1, ...,?N?1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10
3 5 7 2 6 4 9 0 8 1

Sample Output:

9

编译软件:visual studio

编译语言:c语言

参考代码:

#include<cstdio>
#include<algorithm>
using namespace std;
const int maxn = 100010;
int pos[maxn];

int main()
{
?? ?int n, ans = 0;
?? ?scanf("%d", &n);
?? ?int left = n - 1, num;
?? ?for (int i = 0; i < n; i ++ )
?? ?{
?? ??? ?scanf("%d", &num);
?? ??? ?pos[num] = i;
?? ??? ?if (num == i && num != 0)
?? ??? ?{
?? ??? ??? ?left--;
?? ??? ?}
?? ?}
?? ?int k = 1;
?? ?while (left > 0)
?? ?{
?? ??? ?if (pos[0] == 0)
?? ??? ?{
?? ??? ??? ?while (k < n)
?? ??? ??? ?{
?? ??? ??? ??? ?if (pos[k] != k)
?? ??? ??? ??? ?{
?? ??? ??? ??? ??? ?swap(pos[0], pos[k]);
?? ??? ??? ??? ??? ?ans++;
?? ??? ??? ??? ??? ?break;
?? ??? ??? ??? ?}
?? ??? ??? ??? ?k++;
?? ??? ??? ?}
?? ??? ?}

?? ??? ?while (pos[0] != 0)
?? ??? ?{
?? ??? ??? ?swap(pos[0], pos[pos[0]]);
?? ??? ??? ?ans++;
?? ??? ??? ?left--;
?? ??? ?}
?? ?}

?? ?printf("%d\n", ans);
?? ?return 0;
}

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2022-03-06 12:43:52  更:2022-03-06 12:47:58 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/24 4:35:07-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码