IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> 1060Are They Equal -> 正文阅读

[C++知识库]1060Are They Equal

If a machine can save only 3 significant digits, the float numbers 12300 and 12358.9 are considered equal since they are both saved as?0.123×105?with simple chopping. Now given the number of significant digits on a machine and two float numbers, you are supposed to tell if they are treated equal in that machine.

Input Specification:

Each input file contains one test case which gives three numbers?N,?A?and?B, where?N?(<100) is the number of significant digits, and?A?and?B?are the two float numbers to be compared. Each float number is non-negative, no greater than?10100, and that its total digit number is less than 100.

Output Specification:

For each test case, print in a line?YES?if the two numbers are treated equal, and then the number in the standard form?0.d[1]...d[N]*10^k?(d[1]>0 unless the number is 0); or?NO?if they are not treated equal, and then the two numbers in their standard form. All the terms must be separated by a space, with no extra space at the end of a line.

Note: Simple chopping is assumed without rounding.

Sample Input 1:

3 12300 12358.9

Sample Output 1:

YES 0.123*10^5

Sample Input 2:

3 120 128

Sample Output 2:

NO 0.120*10^3 0.128*10^3

编译软件:visual studio

编译语言:c++

参考代码:

#include<iostream>
#include<string>
using namespace std;

int n;

string deal(string s, int& e)
{
?? ?int k = 0;
?? ?while (s.length() > 0 && s[0] == '0')
?? ?{
?? ??? ?s.erase(s.begin());
?? ?}

?? ?if (s[0] == '.')
?? ?{
? ? ? ? s.erase(s.begin());
?? ??? ?while (s.length() > 0 && s[0] == '0')
?? ??? ?{
?? ??? ??? ?s.erase(s.begin());
?? ??? ??? ?e--;
?? ??? ?}
?? ?}
?? ?else
?? ?{
?? ??? ?while (k < s.length() && s[k] != '.')
?? ??? ?{
?? ??? ??? ?k++;
?? ??? ??? ?e++;
?? ??? ?}
?? ??? ?if (k < s.length())
?? ??? ?{
?? ??? ??? ?s.erase(s.begin() + k);
?? ??? ?}
?? ?}

?? ?if (s.length() == 0)
?? ?{
?? ??? ?e = 0;
?? ?}

?? ?int num = 0;
?? ?k = 0;

?? ?string res;
?? ?while (num < n)
?? ?{
?? ??? ?if (k < s.length()) res += s[k++];
?? ??? ?else res += '0';
?? ??? ?num++;
?? ?}

?? ?return res;
}

int main()
{
?? ?string s1, s2, s3, s4;
?? ?cin >> n >> s1 >> s2;

?? ?int e1 = 0, e2 = 0;

?? ?s3 = deal(s1, e1);
?? ?s4 = deal(s2, e2);

?? ?if (s3 == s4 && e1 == e2)
?? ?{
?? ??? ?cout << "YES 0." << s3 << "*10^" << e1 << endl;
?? ?}
?? ?else
?? ?{
?? ??? ?cout << "NO 0." << s3 << "*10^" << e1 << " 0." << s4 << "*10^" << e2 << endl;
?? ?}

?? ?return 0;
}

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2022-03-10 22:13:22  更:2022-03-10 22:17:30 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/24 4:18:22-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码