IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> 1044Shopping in Mars -> 正文阅读

[C++知识库]1044Shopping in Mars

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers:?N?(≤105), the total number of diamonds on the chain, and?M?(≤108), the amount that the customer has to pay. Then the next line contains?N?positive numbers?D1??DN??(Di?≤103?for all?i=1,?,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print?i-j?in a line for each pair of?i?≤?j?such that?Di?+ ... +?Dj?=?M. Note that if there are more than one solution, all the solutions must be printed in increasing order of?i.

If there is no solution, output?i-j?for pairs of?i?≤?j?such that?Di?+ ... +?Dj?>M?with (Di?+ ... +?Dj??M) minimized. Again all the solutions must be printed in increasing order of?i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

编译软件:visual studio

编译语言:c语言

参考代码:

#include<cstdio>
const int N = 100010;

int sum[N];
int n, S, nearS = 100000010;

int upper_bound(int L, int R, int x)
{
?? ?int left = L, right = R, mid;
?? ?while (left < right)
?? ?{
?? ??? ?mid = (left + right) / 2;
?? ??? ?if (sum[mid] > x)
?? ??? ?{
?? ??? ??? ?right = mid;
?? ??? ?}
?? ??? ?else
?? ??? ?{
?? ??? ??? ?left = mid + 1;
?? ??? ?}
?? ?}
?? ?return left;
}

int main()
{
?? ?scanf("%d%d", &n, &S);
?? ?sum[0] = 0;
?? ?for (int i = 1; i <= n; i++)
?? ?{
?? ??? ?scanf("%d", &sum[i]);
?? ??? ?sum[i] += sum[i - 1];
?? ?}

?? ?for (int i = 1; i <= n; i++)
?? ?{
?? ??? ?int ?j = upper_bound(i, n + 1, sum[i - 1] + S);
?? ??? ?if (sum[j - 1] - sum[i - 1] == S)
?? ??? ?{
?? ??? ??? ?nearS = S;
?? ??? ??? ?break;
?? ??? ?}
?? ??? ?else if (j <= n && sum[j] - sum[i - 1] < nearS)
?? ??? ?{
?? ??? ??? ?nearS = sum[j] - sum[i - 1];
?? ??? ?}
?? ?}

?? ?for (int i = 1; i <= n; i++)
?? ?{
?? ??? ?int ?j = upper_bound(i, n + 1, sum[i - 1] + nearS);
?? ??? ?if (sum[j - 1] - sum[i - 1] == nearS)
?? ??? ?{
?? ??? ??? ?printf("%d-%d\n", i, j - 1);
?? ??? ?}
?? ?}
?? ?return 0;
}

  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2022-03-11 21:57:07  更:2022-03-11 21:59:35 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/24 4:23:42-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码