IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> 【PAT】甲级1028 List Sorting (25 分) -> 正文阅读

[C++知识库]【PAT】甲级1028 List Sorting (25 分)

【PAT】甲级1028 List Sorting (25 分)

题目

Input Specification:
Each input file contains one test case. For each case, the first line contains two integers N (≤10
5
) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

测试用例

Sample Input 1:
	3 1
	000007 James 85
	000010 Amy 90
	000001 Zoe 60
Sample Output 1:
	000001 Zoe 60
	000007 James 85
	000010 Amy 90

题解

#include<bits/stdc++.h>
using namespace std;

int n,c;  // 总共输入三行

// 定义学生信息结构体
struct NODE
{
    int no;
    string name;
    int score;
};

int cmp(NODE a, NODE b)
{
    if(c == 1)
    {
        return a.no < b.no;// 从小到大顺序
    }
    else if(c == 2)
    {   // If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
        if(a.name != b.name)
        {
            return a.name < b.name;
        }
        else{
            return a.no < b.no;
        }
    }
    else if(c == 3){
        if(a.score != b.score)
        {
            return a.score < b.score;
        }
        else{
            return a.no < b.no;
        }
    }
}

int main()
{
    cin>>n>>c;
    vector<NODE> node(n); // 定义一个数组存储三个学生的结构体

    // 读入学生信息
    for(int i = 0; i < n; i++)
    {
        cin>>node[i].no>>node[i].name>>node[i].score;
    }

    // 排序  注意第三个参数:定义排序的规则
    sort(node.begin(),node.end(),cmp);

    for(int i = 0; i < n; i++)
    {
        printf("%06d %s %d\n",node[i].no,node[i].name.c_str(),node[i].score);
    }

    return 0;
}
  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2022-04-24 09:11:57  更:2022-04-24 09:12:03 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/23 21:14:43-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码