题目描述
编写程序,统计某旅馆住宿客人的总数和收入总额。要求输入客人的姓名,输出客人编号(2015+顺序号,顺序号4位,如第1位为0001,第2位为0002,依此类推)、姓名、总人数以及收入总额。总人数和收入总额用静态成员,其他属性采用普通的数据成员。旅馆类声明如下:
class Hotel
{
private:
static int totalCustNum; // 顾客总人数
static float totalEarning; // 旅店总收入
static float rent; // 每个顾客的房租
char *customerName; // 顾客姓名
int customerId; // 顾客编号
public:
// totalCustNum++,customerId按照totalCustNum生成
Hotel(char* customer);
~Hotel(); //记得delete customerName
void Display(); //相应输出顾客姓名、顾客编号、总人数、总收入
};
输入
第1行:输入旅馆单个顾客房租
第2行开始,依次输入顾客姓名,0表示输入结束, 姓名的最大字符长度为20
输出
每行依次输出顾客信息和当前旅馆信息。包括顾客姓名,顾客编号,旅馆当前总人数,旅馆当前总收入。
输入样例1
150
张三 李四 王五 0
输出样例1
张三 20150001 1 150
李四 20150002 2 300
王五 20150003 3 450
该题主要考察在类中对静态变量的使用,主要注意使用静态变量记得初始化?
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include <iomanip>
#include<cmath>
#include<cstring>
#include<cctype>
#include<queue>
#include<set>
using namespace std;
class Hotel
{
private:
static int totalCustNum; // 顾客总人数
static float totalEarning; // 旅店总收入
float rent; // 每个顾客的房租
char* customerName; // 顾客姓名
int customerId; // 顾客编号
public:
// totalCustNum++,customerId按照totalCustNum生成
Hotel(char* customer,float evmey);
// ~Hotel(); //记得delete customerName
void Display(); //相应输出顾客姓名、顾客编号、总人数、总收入
};
int Hotel::totalCustNum = 0;
float Hotel::totalEarning = 0;// 记得初始化静态变量
Hotel::Hotel(char* customer,float evmey)
{
// customerName=new char[30];
rent = evmey;
customerName = customer;
totalCustNum++;
customerId = totalCustNum;
totalEarning = totalCustNum * rent;
}
//Hotel::~Hotel()
//{
// delete []customerName;
//}
void Hotel::Display()
{
cout << customerName<<" 2015";
if (totalCustNum == 0) cout << "0000" << ' ';
else if (totalCustNum > 0 && totalCustNum < 10) cout << "000" << totalCustNum << ' ';
else if (totalCustNum >= 10 && totalCustNum < 100)cout << "00" << totalCustNum << ' ';
else if (totalCustNum >= 100 && totalCustNum < 1000)cout << "0" << totalCustNum << ' ';
else if (totalCustNum >= 1000 && totalCustNum <= 9999)cout << totalCustNum << ' ';
cout << totalCustNum << ' ' << totalEarning << endl;
}
int main()
{
float evmey;
char name[30];
cin >> evmey;
while (1)
{
cin >> name;
if (name[0] == '0') break;
Hotel cust(name,evmey);
cust.Display();
cust.~Hotel();
}
return 0;
}
|