前言
1006 超级水的一道排序题,不多解释了。
题目概述
1006 Sign In and Sign Out
At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in’s and out’s, you are supposed to find the ones who have unlocked and locked the door on that day.
Input Specification:
Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:
ID_number Sign_in_time Sign_out_time
where times are given in the format HH:MM:SS , and ID_number is a string with no more than 15 characters.
Output Specification:
For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.
Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
AC代码
#include<iostream>
#include<algorithm>
#include<string>
using namespace std;
const int N = 1e5 + 10;
struct p{
string id;
int hh1, mm1, ss1;
int hh2, mm2, ss2;
};
p ps[N];
bool cmp1(p a, p b)
{
if(a.hh1 != b.hh1) return a.hh1 < b.hh1;
if(a.mm1 != b.mm1) return a.mm1 < b.mm1;
return a.ss1 < b.ss1;
}
bool cmp2(p a, p b)
{
if(a.hh2 != b.hh2) return a.hh2 > b.hh2;
if(a.mm2 != b.mm2) return a.mm2 > b.mm2;
return a.ss2 < b.ss2;
}
int main()
{
int n;
cin >> n;
for(int i = 0; i < n; ++i)
{
cin >> ps[i].id;
scanf("%d:%d:%d", &ps[i].hh1, &ps[i].mm1, &ps[i].ss1);
scanf("%d:%d:%d", &ps[i].hh2, &ps[i].mm2, &ps[i].ss2);
}
sort(ps, ps + n, cmp1);
cout << ps[0].id;
sort(ps, ps + n, cmp2);
cout << " " << ps[0].id << endl;
return 0;
}
分析思路
1.用scanf来读入,这样就不用处理冒号的问题。
2.排序得到答案,找到最早的和最晚的就可以。
文末广告
学习算法和数据结构真的是个很累的过程,不会做只能求助于题解。 因为写代码这个东西基本上是千人千面。同时网络上搜到的题解很多要么用到的是自己还没学到的知识,看不懂;要么内核过于简陋,只能糊弄当前题目,不具有普适性。 如果你是一个喜欢做洛谷,ACwing和PTA的题目的同学,欢迎关注我的博客,我主要在这三个平台上做题,认为有价值和有难度的题目我会写题解发布出来。 TreeTraverler的往期文章
|