IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> C++知识库 -> 【PAT甲级 - C++题解】1125 Chain the Ropes -> 正文阅读

[C++知识库]【PAT甲级 - C++题解】1125 Chain the Ropes

?个人博客:https://blog.csdn.net/Newin2020?spm=1011.2415.3001.5343
📚专栏地址:PAT题解集合
📝原题地址:题目详情 - 1125 Chain the Ropes (pintia.cn)
🔑中文翻译:结绳
📣专栏定位:为想考甲级PAT的小伙伴整理常考算法题解,祝大家都能取得满分!
??如果有收获的话,欢迎点赞👍收藏📁,您的支持就是我创作的最大动力💪

1125 Chain the Ropes

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

[外链图片转存失败,源站可能有防盗链机制,建议将图片保存下来直接上传(img-Mq2Q6ol2-1671843374397)(PAT 甲级辅导.assets/46293e57-aa0e-414b-b5c3-7c4b2d5201e2.jpg)]

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2≤N≤104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:

8
10 15 12 3 4 13 1 15

Sample Output:

14

题意

给定 n 个绳子的长度,每两个绳子合并长度就会减少一半,需要求出所有绳子合并后长度的最大值,输出的是整数(向下取整)。

思路

绳子合并的顺序不同会导致最终的结果不同,例如有三根绳子 {1,2,3} ,如果想让前两个合并再和第三根合并,最终的绳子长度为 ((1+2)/2+3)/2=2.25 ;而如果先让第一根和第三根合并再和第二根合并,最终的绳子长度为 ((1+3)/2+2)/2=2

直接上结论,这其实有一点像哈夫曼树但又不完全相似,我们每次合并都去合并最小的那两根绳子,这样最后得到的长度一定是最大的。

代码

#include<bits/stdc++.h>
using namespace std;

const int N = 10010;
double a[N];
int n;

int main()
{
    cin >> n;
    for (int i = 0; i < n; i++)    cin >> a[i];

    //进行排序
    sort(a, a + n);

    //计算最大长度并输出
    for (int i = 1; i < n; i++)    a[0] = (a[0] + a[i]) / 2;
    cout << (int)a[0] << endl;

    return 0;
}
  C++知识库 最新文章
【C++】友元、嵌套类、异常、RTTI、类型转换
通讯录的思路与实现(C语言)
C++PrimerPlus 第七章 函数-C++的编程模块(
Problem C: 算法9-9~9-12:平衡二叉树的基本
MSVC C++ UTF-8编程
C++进阶 多态原理
简单string类c++实现
我的年度总结
【C语言】以深厚地基筑伟岸高楼-基础篇(六
c语言常见错误合集
上一篇文章      下一篇文章      查看所有文章
加:2022-12-25 10:47:31  更:2022-12-25 10:48:11 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年5日历 -2024/5/19 2:26:02-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码