1052 Linked List Sorting (25 分)
A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.
Input Specification: Each input file contains one test case. For each case, the first line contains a positive N (<10 5 ) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by ?1.
Then N lines follow, each describes a node in the format:
Address Key Next where Address is the address of the node in memory, Key is an integer in [?10 5 ,10 5 ], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.
Output Specification: For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.
Sample Input: 5 00001 11111 100 -1 00001 0 22222 33333 100000 11111 12345 -1 33333 22222 1000 12345 结尾无空行 Sample Output: 5 12345 12345 -1 00001 00001 0 11111 11111 100 22222 22222 1000 33333 33333 100000 -1 结尾无空行
代码如下:
#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<string.h>
#include<cmath>
#include<map>
#include<vector>
#include<queue>
#include<stack>
#include<set>
#include<iostream>
using namespace std;
const int max_n = 100006;
const int INF = (1 << 30);
struct Node
{
int address;
int data;
int next;
}node[max_n], temp;
vector<Node> list;
bool cmp(Node a, Node b)
{
return a.data < b.data;
}
int main()
{
int n;
int head;
scanf("%d %d", &n ,&head);
int address, data, next;
for (int i = 0; i < n; i++)
{
scanf("%d %d %d",&address, &data, &next);
node[address].address = address;
node[address].data = data;
node[address].next = next;
}
int cur = head;
while (cur!=-1)
{
list.push_back(node[cur]);
cur = node[cur].next;
}
sort(list.begin(), list.end(), cmp);
if (list.size()==0)
{
printf("0 -1");
return 0;
}
printf("%d %05d\n", list.size(), list[0].address);
for (int i = 0; i < list.size(); i++)
{
if (i != list.size() - 1)
{
printf("%05d %d %05d\n", list[i].address, list[i].data, list[i + 1].address);
}
else
{
printf("%05d %d -1\n", list[i].address, list[i].data);
}
}
return 0;
}
总结
就如同我在代码里注释的一样,如果使用vector来实现链表的话,就需要判断list.size(),当list.size()=0 时,直接访问list[0]会出现段错误。如果用一个大数组来实现的话可以避免这种特殊情况。
|