L1-017 到底有多二 (15 分)
*文章提供者:海南师范大学 ---- 人工智能教育协会 ---- 周雨歆、刘婧怡、王垚儒
(一)题目要求
一个整数“犯二的程度”定义为该数字中包含2的个数与其位数的比值。如果这个数是负数,则程度增加0.5倍;如果还是个偶数,则再增加1倍。例如数字-13142223336是个11位数,其中有3个2,并且是负数,也是偶数,则它的犯二程度计算为:3/11×1.5×2×100%,约为81.82%。本题就请你计算一个给定整数到底有多二。
输入格式:
输入第一行给出一个不超过50位的整数N。
输出格式:
在一行中输出N犯二的程度,保留小数点后两位。
输入样例1:
-13142223336
输出样例1:
81.82%
(二)代码如下:
方法一:(C)
#include<stdio.h>
#include<string.h>
#define MAXSIZE 60
int main(){
char a[MAXSIZE];
float n=0;
float degree;
scanf("%s",&a);
float length = strlen(a);
for(int i = 0; i < length; i++){
if(a[i] == '2'){
n=n+1;
}
}
if(a[0] == '-'){
degree = (double)n/(length-1) * 1.5;
}
else{
degree = (double)n/length;
}
if(a[(int)length-1]%2 == 0){
degree = degree * 2.0;
}
degree = degree *100;
printf("%.2f%%",degree);
return 0;
}
方法二:(C++)
#include<iostream>
#include<iomanip>
#include<string>
using namespace std;
int main(){
int count=0, n;
string arr;
float result=1, result1=1;
cin>>arr;
n = arr.size();
if((arr[n-1]-'0')%2==0){
result1 += 1;
}
for(int i;i<n;i++){
if(arr[i]=='2'){
count++;
}
}
if(arr[0]=='-'){
result += 0.5;
n--;
}
result1=(double)count/n*result*result1*100;
cout<<setiosflags(ios::fixed)<<setprecision(2);
cout<<result1<<"%"<<endl;
return 0;
}
方法三:(Python)
a = input()
b = 1
m = 1
n = 0
num = len(str(abs(int(a))))
if int(a) < 0:
b += 0.5
if int(a) % 2 == 0:
m += 1
for x in a:
if "2" == x:
n += 1
c = n / num * b* m * 100
print("{:.2f}%".format(c))
诚挚希望有心者指正,渴望简单的方法。
|