IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> PAT甲级1145 Hashing - Average Search Time |散列表平方探测法解决冲突 -> 正文阅读

[数据结构与算法]PAT甲级1145 Hashing - Average Search Time |散列表平方探测法解决冲突

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.
Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 104 . Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 105 .

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

思路

先建散列表然后将数据插入,每次插入如果那个位置已有数据或者一直找不到位置插入则显示该数字cannot be inserted。搜索的时候每次搜索到一个位置次数加1,如果这个位置是该数,或者这个位置是-1(表示没有这个数)则直接退出表示找到了;如果一直到最后都没找到则搜索次数要再加1(不清楚原因)

#include <iostream>
#include <cstdlib>
#include <vector>
#include <iomanip>
using namespace std;
int Tsize, N, M;
bool isPrime(int);
int Hash(int n) { return n % Tsize; }
int main()
{
	cin >> Tsize >> N >> M;
	while (!isPrime(Tsize))
		Tsize++;
	vector<int> vec(Tsize, -1);
	for (int i = 0; i < N; i++)
	{
		int num, flag = 0;
		cin >> num;
		for (int j = 0; j < Tsize; j++)
		{
			int pos = (Hash(num) + j * j) % Tsize;
			if (vec[pos] == -1)
			{
				vec[pos] = num;
				flag = 1;
				break;
			}
		}
		if (!flag)
			cout << num << " cannot be inserted." << endl;
	}
	int total = 0;
	for (int i = 0; i < M; i++)
	{
		int num;
		cin >> num;
		bool found = false;
		for (int j = 0; j < Tsize; j++)
		{
			total++;
			int pos = (Hash(num) + j * j) % Tsize;
			if (vec[pos] == num || vec[pos] == -1)
			{
				found = true;
				break;
			}
		}
		if (!found)
			total++;
	}
	cout << fixed << setprecision(1) << total * 1.0 / M << endl;
	system("pause");
	return 0;
}
bool isPrime(int n)
{
	if (n < 2)
		return false;
	for (int i = 2; i * i <= n; i++)
		if (n % i == 0)
			return false;
	return true;
}
  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2021-08-07 12:20:33  更:2021-08-07 12:22:38 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/25 19:52:34-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码