题目描述:
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits. Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input. Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable. Sample Input
2 6 19 0 Sample Output
10 100100100100100100 111111111111111111
题目分析:
这题看到1、0很容易误以为是一道跟二进制有关的题,但实际上本题跟二进制没什么关系。题意是给你一个数字,让你在这个数的任意倍数中找到一个只有1和0组成的十进制的数字。 看似很难,但只需要用到一个很简单的深度优先搜索。
代码:
#include <iostream>
#include<algorithm>
#define ll long long
using namespace std;
int flag;
ll n,ans;
void DFS(ll x,int step){
if(step>18||flag){
return;
}
if(x%n==0){
ans=x;
flag=1;
return;
}
DFS(x*10,step+1);
DFS(x*10+1,step+1);
}
int main() {
while(cin>>n&&n){
flag=0;
DFS(1,0);
cout<<ans<<endl;
}
return 0;
}
|