IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> PTA甲级 1099 Build A Binary Search Tree (C++) -> 正文阅读

[数据结构与算法]PTA甲级 1099 Build A Binary Search Tree (C++)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node’s key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
  • Both the left and right subtrees must also be binary search trees.

Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
在这里插入图片描述

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N ( ≤ 100 ) N (≤100) N(100) which is the total number of nodes in the tree. The next N N N lines each contains the left and the right children of a node in the format left_index right_index, provided that the nodes are numbered from 0 to N ? 1 N?1 N?1, and 0 is always the root. If one child is missing, then ? 1 ?1 ?1 will represent the NULL child pointer. Finally N N N distinct integer keys are given in the last line.

Output Specification:

For each test case, print in one line the level order traversal sequence of that tree. All the numbers must be separated by a space, with no extra space at the end of the line.

Sample Input:

9
1 6
2 3
-1 -1
-1 4
5 -1
-1 -1
7 -1
-1 8
-1 -1
73 45 11 58 82 25 67 38 42

Sample Output:

58 25 82 11 38 67 45 73 42

Caution:

思路比较简单,先构建好树形,然后进行中序遍历,然后将输入的数组先进行排序后再按照中序遍历的顺序依次填入树中(用到的性质就是二叉搜索树的中序遍历是单调递增的)。

Solution:

// Talk is cheap, show me the code
// Created by Misdirection 2021-08-12 21:44:05
// All rights reserved.

#include <iostream>
#include <vector>
#include <queue>
#include <algorithm>

using namespace std;

vector<vector<int>> tree;

struct Node{
    int num;
    Node *left;
    Node *right;

    Node(int n = 0, Node* l = NULL, Node* r = NULL){
        num = n;
        left = l;
        right = r;
    }
    ~Node(){}
};

vector<Node*> mid;

void findChildren(Node* r){

    if(tree[r -> num][0] != -1) r -> left = new Node(tree[r -> num][0], NULL, NULL);
    if(tree[r -> num][1] != -1) r -> right = new Node(tree[r -> num][1], NULL, NULL);

    if(r -> left != NULL) findChildren(r -> left);
    if(r -> right != NULL) findChildren(r -> right);
    
    return;
}

void midOrder(Node* r){
    // if(r == NULL) return;

    // midOrder(r -> left);
    // cout << r -> num << ' ';
    // midOrder(r -> right);
    // 上面的是检查树形的时候的中序遍历代码

    // 下面的是填入 Node 指针的时候中序遍历代码

    if(r == NULL) return;
    midOrder(r -> left);
    mid.push_back(r);
    midOrder(r -> right);
}

void preOrder(Node *r){
    if(r == NULL) return;

    cout << r -> num << ' ';
    preOrder(r -> left);
    preOrder(r -> right);
}



int main(){
    int n;
    cin >> n;
    
    tree.resize(n, vector<int>(2));

    for(int i = 0; i < n; ++i) scanf("%d %d", &tree[i][0], &tree[i][1]);

    Node *root = new Node(0, NULL, NULL);
    findChildren(root);
    
    // 中序遍历和前序遍历以检查树形
    // midOrder(root);
    // cout << endl;
    // preOrder(root);
    // cout << endl;

    mid.clear();
    midOrder(root);
    
    vector<int> num(n);

    for(int i = 0; i < n; ++i) scanf("%d", &num[i]);
    sort(num.begin(), num.end());

    for(int i = 0; i < n; ++i) mid[i] -> num = num[i];
    // 检查填的对不对
    // preOrder(root);
    // cout << endl;

    // 现在层次遍历
    queue<Node*> q;
    q.push(root);

    while(!q.empty()){
        printf("%d", q.front() -> num);
        
        if(q.front() -> left != NULL) q.push(q.front() -> left);
        if(q.front() -> right != NULL) q.push(q.front() -> right);
        q.pop();

        if(q.empty()) printf("\n");
        else printf(" ");
    }

    return 0;
}

在这里插入图片描述

  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2021-08-13 12:32:05  更:2021-08-13 12:33:28 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/25 20:50:19-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码