IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> 平衡二叉查找树 (AVL Tree) -> 正文阅读

[数据结构与算法]平衡二叉查找树 (AVL Tree)

?平衡二叉查找树(AVL Tree)

平衡二叉查找树是空树或者一种结构平衡的二叉查找树,即叶节点高度差的绝对值不超过1,并且左右两个子树都是一棵平衡二叉树。

如果在AVL树中进行插入或删除节点,可能导致AVL树失去平衡,这种失去平衡的二叉树可以概括为四种姿态:LL(左左)、RR(右右)、LR(左右)、RL(右左)。

LL:LeftLeft,也称“左左”。插入或删除一个节点后,根节点的左孩子(Left Child)的左孩子? ? ? ?(Left?Child)还有非空节点,导致根节点的左子树高度比右子树高度高2,AVL树失去平衡。

RR:RightRight,也称“右右”。插入或删除一个节点后,根节点的右孩子(Right Child)的右孩子 (Right Child)还有非空节点,导致根节点的右子树高度比左子树高度高2,AVL树失去平衡。

LR:LeftRight,也称“左右”。插入或删除一个节点后,根节点的左孩子(Left Child)的右孩子(Right Child)还有非空节点,导致根节点的左子树高度比右子树高度高2,AVL树失去平衡。

RL:RightLeft,也称“右左”。插入或删除一个节点后,根节点的右孩子(Right Child)的左孩子(Left Child)还有非空节点,导致根节点的右子树高度比左子树高度高2,AVL树失去平衡。

平衡二叉树的最少结点数:n(h)=n(h-1)+n(h-2)+1

给定结点数为n的AVL树的最大高度为O(log2 n)

平衡二叉树的调整

左单旋

treePtr singleLeft(treePtr T){
	treePtr tmpPtr;
	tmpPtr = T;
	T = T->Left;
	tmpPtr->Left = T->Right;
	T->Right = tmpPtr;
	tmpPtr->Height = max(GetHeight(tmpPtr->Left),GetHeight(tmpPtr->Right))+1;
	T->Height =  max(GetHeight(T->Left),GetHeight(T->Right))+1;
	return T;
}

右单旋

treePtr singleRight(treePtr T){
	treePtr tmpPtr;
	tmpPtr = T;
	T = T->Right;
	tmpPtr->Right = T->Left;
	T->Left = tmpPtr;
	tmpPtr->Height = max(GetHeight(tmpPtr->Left),GetHeight(tmpPtr->Right))+1;
	T->Height =  max(GetHeight(T->Left),GetHeight(T->Right))+1;
	return T;
}

LR旋转

左结点进行右单旋,然后对其父结点(即当前结点)进行左单旋;

treePtr LeftRight(treePtr T){
	T->Left = singleRight(T->Left);
	return singleLeft(T);
}

RL旋转

右结点进行左单旋,然后对其父结点(即当前结点)进行右单旋;

treePtr RightLeft(treePtr T){
	T->Right = singleLeft(T->Right);
	return singleRight(T);
}

例题:Root of AVL Tree

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ? ?

?Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer?N?(≤20) which is the total number of keys to be inserted. Then?N?distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

?Sample Output 1:

70

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

Demo:

#include<iostream>
using namespace std;
typedef struct tree* treePtr;
struct tree{
	int Data=0;
	int Height=0;
	treePtr Left=NULL;
	treePtr Right=NULL;
};
int GetHeight(treePtr T){              //获取深度
	if(!T) return -1;
	else return T->Height;
}
treePtr singleLeft(treePtr T){         //左单旋
	treePtr tmpPtr;
	tmpPtr = T;
	T = T->Left;
	tmpPtr->Left = T->Right;
	T->Right = tmpPtr;
	tmpPtr->Height = max(GetHeight(tmpPtr->Left),GetHeight(tmpPtr->Right))+1;
	T->Height =  max(GetHeight(T->Left),GetHeight(T->Right))+1;
	return T;
}
treePtr singleRight(treePtr T){        //右单旋
	treePtr tmpPtr;
	tmpPtr = T;
	T = T->Right;
	tmpPtr->Right = T->Left;
	T->Left = tmpPtr;
	tmpPtr->Height = max(GetHeight(tmpPtr->Left),GetHeight(tmpPtr->Right))+1;
	T->Height =  max(GetHeight(T->Left),GetHeight(T->Right))+1;
	return T;
}
treePtr LeftRight(treePtr T){          //LR旋转
	T->Left = singleRight(T->Left);
	return singleLeft(T);
}
treePtr RightLeft(treePtr T){          //RL旋转
	T->Right = singleLeft(T->Right);
	return singleRight(T);
}
treePtr NewTree(int t, treePtr T){     //增加结点并完成平衡
	if(T == NULL){
		T = new tree;
		T->Data = t;
		T->Left = NULL;
		T->Right = NULL;
		T->Height = 0;
	}
	else if(t < T->Data){
		T->Left = NewTree (t, T->Left);
		if(GetHeight(T->Left) - GetHeight(T->Right) == 2){
			if(t < T->Left->Data) T = singleLeft(T);
			else T = LeftRight(T);
		}
	}
	else if(t > T->Data){
		T->Right = NewTree (t, T->Right);
		if(GetHeight(T->Right) - GetHeight(T->Left) == 2){
			if(t > T->Right->Data) T = singleRight(T);
			else T = RightLeft(T);
		}
	}
	T->Height = max(GetHeight(T->Left), GetHeight(T->Right)) + 1;
	return T;
}
int main(){
	int N;
	int data;
	treePtr tree = NULL;
	cin>>N;
	while(N--){
		cin>>data;
		tree = NewTree(data, tree);
	}
	if(tree) cout<<tree->Data<<endl;
	return 0;
}

  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2021-08-14 14:21:25  更:2021-08-14 14:21:47 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/25 20:49:43-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码