IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> Game Prediction acm入门 day3---贪心算法 第四题 -> 正文阅读

[数据结构与算法]Game Prediction acm入门 day3---贪心算法 第四题

Suppose there are M people, including you, playing a special card
game. At the beginning, each player receives N cards. The pip of a
card is a positive integer which is at most N*M. And there are no two
cards with the same pip. During a round, each player chooses one card
to compare with others. The player whose card with the biggest pip
wins the round, and then the next round begins. After N rounds, when
all the cards of each player have been chosen, the player who has won
the most rounds is the winner of the game. Given your cards received
at the beginning, write a program to tell the maximal number of rounds
that you may at least win during the whole game.

Input

The input consists of several test cases. The first line of each case
contains two integers m (2 <= m <= 20) and n (1 <= n <= 50),
representing the number of players and the number of cards each player
receives at the beginning of the game, respectively. This followed by
a line with n positive integers, representing the pips of cards you
received at the beginning. Then a blank line follows to separate the
cases.

The input is terminated by a line with two zeros.

Output

For each test case, output a line consisting of the test case number
followed by the number of rounds you will at least win during the
game.

题意:m个人打牌,每人n张牌,牌的点数最大不超过n*m且不重复,问最少能赢多少把。

汗,反向被贪心,也就是说,只要这一把场上还有人拥有比你大的牌,你就必输= = 所以思路就是将自己所拥有的牌从大到小排序,每次都打最大牌,每次出牌时先遍历在场所有人的未打出的牌(自己的则事先置1不用遍历),然后只要场上没有比你大的牌就赢,没有就输同时置1表示已被打出。

Sample Input

2 5
1 7 2 10 9

6 11
62 63 54 66 65 61 57 56 50 53 48

0 0

Sample Output

Case 1: 2
Case 2: 4
#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;
int p[50];
int mat[1001];
bool cmp(int a, int b)
{
	return a > b;
}
int main()
{
	int n, m;
	int cnt = 1;
	while (scanf("%d %d", &m, &n) != EOF && n && m)
	{
		memset(mat, 0, sizeof(mat));
		memset(p, 0, sizeof(p));
		int max = n * m;
		for (int i = 0; i < n; i++)
		{
			scanf("%d", &p[i]);
			mat[p[i]] = 1;//将自己拥有的牌置1
		}
		sort(p, p + n, cmp);
		int num = 0;
		for (int i = 0; i < n; i++)
		{
			int flag = 0;
			for (int x = p[i]+1; x <= n * m; x++)
			{
				if (mat[x] == 0) {
					flag = 1;//存在更大的牌
					mat[x] = 1;
					break;
				}
				
			}
			if (flag == 0) num++;
		}

		printf("Case %d: %d\n",cnt++, num);
	}
}
  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2021-08-31 15:42:15  更:2021-08-31 15:43:37 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 0:28:19-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码