IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> 1028 List Sorting (25 分) java 题解 -> 正文阅读

[数据结构与算法]1028 List Sorting (25 分) java 题解

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers?N?(≤105) and?C, where?N?is the number of records and?C?is the column that you are supposed to sort the records with. Then?N?lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in?N?lines. That is, if?C?= 1 then the records must be sorted in increasing order according to ID's; if?C?= 2 then the records must be sorted in non-decreasing order according to names; and if?C?= 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9

Sample Output 3:

000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90

题目描述:

将一些学生信息按其不同属性选择性的排序。

解题思路:

将学生信息封装到类,按排序类别利用Compator比较器实现定制排序。

java代码:

import java.io.*;
import java.util.*;

public class Main {
	public static void main(String[] args) throws IOException {
		BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
		String[] split = br.readLine().split(" ");
		int n = Integer.parseInt(split[0]);
		int type = Integer.parseInt(split[1]);
		List<Student1028> list = new ArrayList<>();
		for(int i = 0; i < n;i++) {
			split = br.readLine().split(" ");
			String id = split[0];
			String name = split[1];
			int grade = Integer.parseInt(split[2]);
			list.add(new Student1028(id, name, grade));
		}
		if(type == 1) {
			Collections.sort(list, new Comparator<Student1028>() {
				@Override
				public int compare(Student1028 o1, Student1028 o2) {
					return o1.id.compareTo(o2.id);
				}
			});
		}else if(type == 2) {
			Collections.sort(list, new Comparator<Student1028>() {
				@Override
				public int compare(Student1028 o1, Student1028 o2) {
					if(!o1.name.equals(o2.name)) {
						return o1.name.compareTo(o2.name);
					}else {
						return o1.id.compareTo(o2.id);
					}
				}
			});
		}else {
			Collections.sort(list, new Comparator<Student1028>() {
				@Override
				public int compare(Student1028 o1, Student1028 o2) {
					if(o1.grade != o2.grade) {
						return o1.grade - o2.grade;
					}else {
						return o1.id.compareTo(o2.id);
					}
				}
			});
		}
		StringBuilder builder = new StringBuilder();
		for(Student1028 data : list) {
//			System.out.print(data);
			builder.append(data);
		}
		System.out.print(builder.toString());
	}
}
class Student1028{
	String id;
	String name;
	int grade;
	
	public Student1028(String id, String name, int grade) {
		this.id = id;
		this.name = name;
		this.grade = grade;
	}

	@Override
	public String toString() {
		return id + " " + name + " " + grade + "\n";
	}
}

PTA提交截图:

  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2021-10-03 17:18:25  更:2021-10-03 17:18:44 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年5日历 -2024/5/17 10:48:01-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码