IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> 中国大学MOOC-陈越、何钦铭-数据结构-02-线性结构3 Reversing Linked List (25 分) -> 正文阅读

[数据结构与算法]中国大学MOOC-陈越、何钦铭-数据结构-02-线性结构3 Reversing Linked List (25 分)

原题目:

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10^5) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Data Next

where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:
00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
结尾无空行
Sample Output:
00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1
结尾无空行

题解:

关键在于使用结构数组

这道题的情况很适合使用结构数组解决,二手信息如下:

此图截自于《The C Programming Language》中文译本P116。
于是有:

struct GNode{
    int data;
    int next;
}NodeTab[100000];
#include <stdio.h>

struct GNode{
    int data;
    int next;
}NodeTab[100000];
int main()
{
    int head,N,K;
    scanf("%d%d%d",&head,&N,&K);
    for(int i=0;i<N;i++){
        int address;
        scanf("%d",&address);
        scanf("%d%d",&NodeTab[address].data,&NodeTab[address].next);
    }
    //至此输入完成,链表储存完毕
    int p=head,cnt=0;
    while(p>=0){
        cnt++;
        p=NodeTab[p].next;
    }
    N=cnt;
    //这段代码是为了排除“有输入样例包含不在链表中的结点”的情况
    int k=N/K;
    int pre,PreHead;
    p=head;
    for(int j=0;j<k;j++){
        pre=p;
        p=NodeTab[p].next;
        int temp=pre;
        for(int i=1;i<K;i++){
            int temp=NodeTab[p].next;
            NodeTab[p].next=pre;//reverse
            pre=p;
            p=temp;//移向下一个结点
        }//此时p为下一组中第一个,pre为本组最后一个
        NodeTab[temp].next=p;
        if(j==0){
            head=pre;
        }else{
            NodeTab[PreHead].next=pre;
        }
        PreHead=temp;
    }
    //这段代码把N分成N/K组,对每组进行reverse,
    //并在相邻组之间通过PreHead、temp等变量实现连接
    p=head;
    while(p>=0){
        printf("%05d %d ",p,NodeTab[p].data);
        if(NodeTab[p].next==-1)
            printf("-1\n");
        else printf("%05d\n",NodeTab[p].next);
        p=NodeTab[p].next;
    }
    //这段代码是为了打印
    return 0;
}

结果:

在这里插入图片描述

心得:

这道题使用正确的数据结构之后,代码量只有不到50行,可见数据结构选择的重要性,学会更多种类的数据结构,就能在多种不同情况下得心应手。

  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2021-10-17 12:14:11  更:2021-10-17 12:16:34 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 7:28:41-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码