IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> 中国大学MOOC-陈越、何钦铭-数据结构(第一次课1-2) -> 正文阅读

[数据结构与算法]中国大学MOOC-陈越、何钦铭-数据结构(第一次课1-2)

01-复杂度2 Maximum Subsequence Sum

问题描述:

Given a sequence of?K?integers {?N1?,?N2?, ...,?NK??}. A continuous subsequence is defined to be {?Ni?,?Ni+1?, ...,?Nj??} where?1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer?K?(≤10000). The second line contains?K?numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices?i?and?j?(as shown by the sample case). If all the?K?numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21
  • 结尾无空行

Sample Output:

10 1 4
  • 结尾无空行

C语言的实现:

#include <stdio.h>
void MaxSum(int arr[], int n)
{
    int p = 0, q = 0, w = 0;
    for (p = 0; p < n; p++)
    {
        if (arr[p] > 0)
        {
            q++;
        }
    }
    if (q == 0)
    {
        for (p = 0; p < n; p++)
        {
            if (arr[p] == 0)
                w++;
        }
    if (w > 0)
        printf("%d %d %d", 0, 0, 0);
    }
    if (q == 0 && w == 0)
        printf("%d %d %d", 0, arr[0], arr[n-1]);
    if (q > 0)
    {
        int MAXsum = 0, THISsum = 0;
        int a = 0, b = 0, c = 0;
        for (int i = 0; i < n; i++)
        {
            THISsum += arr[i];
            if (THISsum > MAXsum)
            {
                a = c;
                MAXsum = THISsum;
                b = i;
            }
            else if (THISsum < 0)
            {
                THISsum = 0;
                c = i + 1;
            }
        }
        printf("%d %d %d", MAXsum, arr[a], arr[b]);
    }
}
int main()
{
    int n;
    scanf("%d", &n);
    int arr[100000];
    for (int i = 0; i < n; i++)
    {
        scanf("%d", &arr[i]);
    }
    MaxSum(arr, n);
    return 0;
}

  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2021-10-18 17:38:08  更:2021-10-18 17:38:38 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 7:40:05-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码