IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> 7-9 Huffman Codes (30 分)- C语言实现 -> 正文阅读

[数据结构与算法]7-9 Huffman Codes (30 分)- C语言实现

太心累了,主要是一开始建堆出现了小问题,导致测试点一直没过。心烦意乱,采用printf调试(bushi),终于找出来了,是因为child的范围没考虑,忘记限制2*i<N

简单记录下要点,吃饭去了:

哈夫曼编码要点

1. 编码长度之和一定等于哈夫曼编码的长度之和,也就是哈夫曼树各个叶结点的路径之和,所以采用哈夫曼树主要就是为了算出路径长度,图省事,我也没建立树,直接算总和。

2. 要满足前缀码都不相同,cyll在mooc上采用的是构建树的方法去看是否有字符落在不是叶节点上,我偷懒直接采用strcmp暴力遍历

满足这两点就可以算得上是最优编码了。

原题

In 1953, David A. Huffman published his paper "A Method for the Construction of Minimum-Redundancy Codes", and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string "aaaxuaxz", we can observe that the frequencies of the characters 'a', 'x', 'u' and 'z' are 4, 2, 1 and 1, respectively. We may either encode the symbols as {'a'=0, 'x'=10, 'u'=110, 'z'=111}, or in another way as {'a'=1, 'x'=01, 'u'=001, 'z'=000}, both compress the string into 14 bits. Another set of code can be given as {'a'=0, 'x'=11, 'u'=100, 'z'=101}, but {'a'=0, 'x'=01, 'u'=011, 'z'=001} is NOT correct since "aaaxuaxz" and "aazuaxax" can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer?N?(2≤N≤63), then followed by a line that contains all the?N?distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] ... c[N] f[N]

where?c[i]?is a character chosen from {'0' - '9', 'a' - 'z', 'A' - 'Z', '_'}, and?f[i]?is the frequency of?c[i]?and is an integer no more than 1000. The next line gives a positive integer?M?(≤1000), then followed by?M?student submissions. Each student submission consists of?N?lines, each in the format:

c[i] code[i]

where?c[i]?is the?i-th character and?code[i]?is an non-empty string of no more than 63 '0's and '1's.

Output Specification:

For each test case, print in each line either "Yes" if the student's submission is correct, or "No" if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

结尾无空行

Sample Output:

Yes
Yes
No
No

结尾无空行

解答

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
//如果用struct的话可以真正实现哈夫曼树
//但这道题目其实只要求我们求出哈夫曼编码的长度,所以可以采用整型变量作数组类型
int N;
int char_weight[255];
int cnt;//the size of number
typedef struct Node* PtrNode;
typedef struct Node{
    int data;
    PtrNode left;
    PtrNode right;
}Node;
typedef PtrNode Tree;
void Precdown(int heap[],int p){
    int tmp=heap[p];
    int i,child;
    for(i=p;2*i<=N;i=child){
        child=2*i;
        if(child<N && heap[child+1]<heap[child])child++;
        if(heap[child]<tmp)heap[i]=heap[child];
        else break; 
    }
    heap[i]=tmp;
}
void Precup(int heap[],int p){
    int tmp=heap[p];
    int i;
    for(i=p;i>1;i/=2){
        if(heap[i/2]>tmp){
            heap[i]=heap[i/2];
        }else break;
    }
    heap[i]=tmp;
}
int  DeleteHeap(int heap[]){
    int min=heap[1];
    heap[1]=heap[N];
    N--;
    Precdown(heap,1);
    return min;
}
void InsertHeap(int heap[],int x){
    N++;
    heap[N]=x;
    Precup(heap,N);
}
void CreateMinHeap(int heap[]){

    int i;
    for(i=N/2;i>0;i--){
        Precdown(heap,i);
    }
}
int BuildHuff(int heap[]){
    int length=0;
    int v1,v2;
    int root;
    while(N>1){
        v1=DeleteHeap(heap);
        v2=DeleteHeap(heap);
        root=v1+v2;
        length+=root;
        InsertHeap(heap,root);
    }
    return length;
}
int Judge(int length){
    char c[100][100];
    int total=0;
    int num[255]={0};
    int i=0,j=0;
    int slength;
    char ch;
    int l1,l2;
    for(i=0;i<cnt;i++){
        scanf(" %c",&ch);
        scanf(" %s",c[i]);
        total+=char_weight[ch]*strlen(c[i]);
    }
    if(total!=length)return 0;//权值之和不同
    //接下看有无重复的前缀码
    else{
        for(i=0;i<cnt;i<i++){
            for(j=0;j<i;j++){
                slength=(l1=strlen(c[i]))<(l2=strlen(c[j]))?l1:l2;
                if(!strncmp(c[i],c[j],slength))return 0;
            }
        }
    }
    return 1;
}
int main(){
    int i,j;
    int weight;
    char ch;
    int ret;
    int M;//the number of tests
    scanf("%d",&N);
    int heap[100];//start from 1
    heap[0]=-1;
    cnt=N;
    for(i=0;i<N;i++){
        scanf(" %c %d",&ch,&weight);
        heap[i+1]=weight;
        char_weight[ch]=weight;
    }
    CreateMinHeap(heap);
    int length=BuildHuff(heap);
    scanf("%d",&M);
    for(i=0;i<M;i++){
        ret=Judge(length);
        if(ret)printf("Yes\n");
        else printf("No\n");
    }
    return 0;
}

比较混乱,有闲情逸致再来修改总结。挥挥~

?

  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2021-11-18 11:25:30  更:2021-11-18 11:26:39 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 11:30:53-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码