IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> POJ 2048 Anagram Groups[字符串哈希与排序] -> 正文阅读

[数据结构与算法]POJ 2048 Anagram Groups[字符串哈希与排序]

题目

World-renowned Prof. A. N. Agram’s current research deals with large anagram groups. He has just found a new application for his theory on the distribution of characters in English language texts. Given such a text, you are to find the largest anagram groups.
A text is a sequence of words. A word w is an anagram of a word v if and only if there is some permutation p of character positions that takes w to v. Then, w and v are in the same anagram group. The size of an anagram group is the number of words in that group. Find the 5 largest anagram groups.

题目大意

输入一系列的单词,每一个单词占一行,将所有相同的字母及个数组成的单词划分为同一类,最后输出数目最多的五类,相同条件下按字典序输出。

Input

The input contains words composed of lowercase alphabetic characters, separated by whitespace(or new line). It is terminated by EOF. You can assume there will be no more than 30000 words.

Output

Output the 5 largest anagram groups. If there are less than 5 groups, output them all. Sort the groups by decreasing size. Break ties lexicographically by the lexicographical smallest element. For each group output, print its size and its member words. Sort the member words lexicographically and print equal words only once.

Sample Input

undisplayed
trace
tea
singleton
eta
eat
displayed
crate
cater
carte
caret
beta
beat
bate
ate
abet

Sample Output

Group of size 5: caret carte cater crate trace .
Group of size 4: abet bate beat beta .
Group of size 4: ate eat eta tea .
Group of size 1: displayed .
Group of size 1: singleton .

分析

本题既然表示将所有相同组成成分的单词作为一类,那么我们可以对输入的单词进行统计,找出对应的组成,并作为同一类别的判断标准,同时保留原单词,以作输出。先将所有的单词重新排序,确定位置,使得每一类的单词都集中在一处。随后计算同一类的数目,对每一类进行排序,最后注意判断字典序,保持顺序的输出。

代码

#include<iostream>
#include<algorithm>
#include<cstring>

using namespace std;

struct Word{//单词的输入
	char ord[30];//组成成分
	char sou[30];//原单词
}w[30000];

struct seq{//同一类的单词序列
	int times;//次数
	int first;//首个单词的位置
	int end;//最后一个单词的位置
}v[30000];

bool cmp_w(Word x,Word y){//用于对所有单词排序
	if(strcmp(x.ord,y.ord)==0)
		return strcmp(x.sou,y.sou)<0?true:false;
	return strcmp(x.ord,y.ord)<0?true:false;
}
bool cmp_v(seq x,seq y){//用于判断同一类的次数相同时的输出顺序
	if(x.times == y.times)
		return strcmp(w[x.first].sou,w[y.first].sou)<0?true:false;
	return x.times>y.times;
}

int main(){
	char str[100];
	char tmp[100];
	int n = 0;
	while(~scanf("%s",str)){
		strcpy(w[n].sou,str);
		sort(str,str+strlen(str));//原单词排序得到标识
		strcpy(w[n].ord,str);
		++n;
	}
	sort(w,w+n,cmp_w);//将单词排序
	int k = 0;
	for(int i = 0;i<n;++i){//寻找同一类的单词
		int cnt = 0,t = i;
		while(!strcmp(w[i].ord,w[i+1].ord)&&i<n){
			++i;
			++cnt;
		}
		v[k].first = t;//标记这一类单次的起止位置
		v[k].end = i;
		v[k].times = cnt+1;
		++k;
	}
	sort(v,v+k,cmp_v);//对每一类进行排序
	for(int i = 0;i<5&&i<k;++i){
		printf("Group of size %d: %s",v[i].times,w[v[i].first].sou);
		for(int j = v[i].first+1;j<=v[i].end;++j)
			if(strcmp(w[j].sou,w[j-1].sou)!=0)
				printf(" %s",w[j].sou);
		printf(" .\n");
	}
	return 0;
}
  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2022-01-25 10:49:54  更:2022-01-25 10:52:10 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 19:22:44-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码