1018 Public Bike Management (30 point(s))
☆AVL树,层序遍历,完全二叉树
题目
An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.
Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print YES if the tree is complete, or NO if not.
Sample Input 1:
5
88 70 61 63 65
Sample Output 1:
70 63 88 61 65
YES
Sample Input 2:
8
88 70 61 96 120 90 65 68
Sample Output 2:
88 65 96 61 70 90 120 68
NO
思路
题意
给出n个结点,按照结点输入的顺序简历AVL树。层序遍历输出AVL树的结点,并判断是否是完全二叉树。
分析
题意很明确,考察难点主要在建AVL树。判断完全二叉树可以在层序遍历的同时判断,每次进队的时候不管左右孩子是否为NULL 统统入队,每次出队的时候判断是否为空,不为空就按照正常的层序遍历,如果为空则循环出队,如果之后的出队结点还有非空结点,则代表不是完全二叉树。
代码
#include<iostream>
#include<queue>
#include<cmath>
using namespace std;
int n, a, cnt = 0;
bool IsC = true;
struct node {
int key;
node* left, * right;
};
node* root = NULL;
queue<node*> q;
node* RR(node* root) {
node* t = root->right;
root->right = t->left;
t->left = root;
return t;
}
node* LL(node* root) {
node* t = root->left;
root->left = t->right;
t->right = root;
return t;
}
node* LR(node* root) {
root->left = RR(root->left);
return LL(root);
}
node* RL(node* root) {
root->right = LL(root->right);
return RR(root);
}
int getHeight(node* root) {
if (root == NULL) return 0;
return max(getHeight(root->left), getHeight(root->right)) + 1;
}
node* insert(node* root, int key) {
if (!root) {
root = new node;
root->key = key;
root->left = root->right = NULL;
}
else if (key < root->key) {
root->left = insert(root->left, key);
if (getHeight(root->left) - getHeight(root->right) == 2)
root = key < root->left->key ? LL(root) : LR(root);
}
else {
root->right = insert(root->right, key);
if (getHeight(root->left) - getHeight(root->right) == -2)
root = key > root->right->key ? RR(root) : RL(root);
}
return root;
}
int main() {
scanf("%d", &n);
for (int i = 0; i < n; i++) {
scanf("%d", &a);
root = insert(root, a);
}
node* t;
q.push(root);
while (!q.empty()){
t = q.front();
q.pop();
if (t) {
q.push(t->left);
q.push(t->right);
cnt++;
printf("%d%s", t->key, cnt == n ? "\n" : " ");
}
else {
while (!q.empty()){
t = q.front();
if (t) {
IsC = false;
break;
}
else
q.pop();
}
}
}
if (IsC) printf("YES\n");
else printf("NO\n");
return 0;
}
注意
|