IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> 1018 Public Bike Management (30 point(s)) PAT(AVL树,层序遍历,完全二叉树) -> 正文阅读

[数据结构与算法]1018 Public Bike Management (30 point(s)) PAT(AVL树,层序遍历,完全二叉树)

1018 Public Bike Management (30 point(s))

AVL树,层序遍历,完全二叉树

题目

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

F1.jpgF2.jpg
F3.jpgF4.jpg

Now given a sequence of insertions, you are supposed to output the level-order traversal sequence of the resulting AVL tree, and to tell if it is a complete binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤ 20). Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, insert the keys one by one into an initially empty AVL tree. Then first print in a line the level-order traversal sequence of the resulting AVL tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line. Then in the next line, print YES if the tree is complete, or NO if not.

Sample Input 1:

5
88 70 61 63 65

Sample Output 1:

70 63 88 61 65
YES

Sample Input 2:

8
88 70 61 96 120 90 65 68

Sample Output 2:

88 65 96 61 70 90 120 68
NO

思路

题意

给出n个结点,按照结点输入的顺序简历AVL树。层序遍历输出AVL树的结点,并判断是否是完全二叉树。

分析

题意很明确,考察难点主要在建AVL树。判断完全二叉树可以在层序遍历的同时判断,每次进队的时候不管左右孩子是否为NULL统统入队,每次出队的时候判断是否为空,不为空就按照正常的层序遍历,如果为空则循环出队,如果之后的出队结点还有非空结点,则代表不是完全二叉树。

代码

#include<iostream>
#include<queue>
#include<cmath>
using namespace std;

int n, a, cnt = 0;
bool IsC = true;

struct node {
	int key;
	node* left, * right;
};
node* root = NULL;
queue<node*> q;

node* RR(node* root) {
	node* t = root->right;
	root->right = t->left;
	t->left = root;
	return t;
}

node* LL(node* root) {
	node* t = root->left;
	root->left = t->right;
	t->right = root;
	return t;
}

node* LR(node* root) {
	root->left = RR(root->left);
	return LL(root);
}

node* RL(node* root) {
	root->right = LL(root->right);
	return RR(root);
}

int getHeight(node* root) {
	if (root == NULL) return 0;
	return max(getHeight(root->left), getHeight(root->right)) + 1;
}

node* insert(node* root, int key) {
	if (!root) {
		root = new node;
		root->key = key;
		root->left = root->right = NULL;
	}
	else if (key < root->key) {
		root->left = insert(root->left, key);
		if (getHeight(root->left) - getHeight(root->right) == 2)
			root = key < root->left->key ? LL(root) : LR(root);
	}
	else {
		root->right = insert(root->right, key);
		if (getHeight(root->left) - getHeight(root->right) == -2)
			root = key > root->right->key ? RR(root) : RL(root);
	}
	return root;
}

int main() {
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%d", &a);
		root = insert(root, a);
	}
	node* t;
	q.push(root);
	while (!q.empty()){
		t = q.front();
		q.pop();
		if (t) {
			q.push(t->left);
			q.push(t->right);
			cnt++;
			printf("%d%s", t->key, cnt == n ? "\n" : " ");
		}
		else {
			while (!q.empty()){
				t = q.front();
				if (t) {
					IsC = false;
					break;
				}
				else
					q.pop();
			}
		}
	}
	if (IsC) printf("YES\n");
	else printf("NO\n");

	return 0;
}

注意

  • 熟练掌握AVL树建树的方法
  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2022-03-03 16:39:43  更:2022-03-03 16:42:01 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 15:39:04-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码