A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties: The left subtree of a node contains only nodes with keys less than the node’s key. The right subtree of a node contains only nodes with keys greater than or equal to the node’s key. Both the left and right subtrees must also be binary search trees. If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST. Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.
题意
给出N个正整数来作为一棵二叉排序树的结点插入顺序,问:这串序列是否是该二叉排序树的先序序列或是该二叉排序树的镜像树的先序序列。所谓镜像树是指交换二叉树的所有结点的左右子树而形成的树(也即左子树所有结点数据域大于或等于根结点,而根结点数据域小于右子树所有结点的数据域)。如果是镜像树,则输出 YES,并输出对应的树的后序序列;否则,输出NO。
Sample Input 1:
7
8 6 5 7 10 8 11
Sample Output 1:
YES
5 7 6 8 11 10 8
Sample Input 2:
7
8 10 11 8 6 7 5
Sample Output 2:
YES
11 8 10 7 5 6 8
Sample Input 3:
7
8 6 8 5 10 9 11
Sample Output 3:
NO
思路
- 构建一颗二叉搜索树,判断其先序序列是否和输入顺序一样
- 若一样,输出YES,和后序序列;若不一样,检查其镜像二叉树,其余和1一样
- 构造镜像二叉树。
法一:将原有的二叉搜索树,递归交换左右子树 法二:再建立一颗树,建立时条件与1.相反 - 若镜像树先序和输入一样,输出YES和后序序列;不一样,输出NO,结束
注意
- 结尾无空格(PAT习惯)
- 插入相同元素时,按习惯是不插入,但这题要求插入到右边
代码
#include<iostream>
using namespace std;
int n, cnt = 0;
int dt[1001], pre_data[1001], post_data[1001];
int flag;
struct Tnode{
int val;
Tnode* left;
Tnode* right;
Tnode(int x) : val(x), left(NULL), right(NULL){}
};
void Insert(Tnode* &root, int x){
if(root == NULL){
root = new Tnode(x);
return ;
}
if(flag == 1){
if(root->val <= x)
Insert(root->right, x);
else
Insert(root->left, x);
}
else{
if(root->val > x)
Insert(root->right, x);
else
Insert(root->left, x);
}
}
Tnode* Create(){
Tnode* root = NULL;
for(int i=0; i<n; i++)
Insert(root, dt[i]);
return root;
}
void PreOrder(Tnode* root){
if(root == NULL)
return ;
pre_data[cnt++] = root->val;
PreOrder(root->left);
PreOrder(root->right);
}
void PostOrder(Tnode* root){
if(root == NULL)
return ;
PostOrder(root->left);
PostOrder(root->right);
post_data[cnt++] = root->val;
}
bool Check(Tnode* root){
for(int i=0; i<n; i++){
if(dt[i] != pre_data[i])
return false;
}
printf("YES\n");
cnt = 0;
PostOrder(root);
for(int i=0; i<n; i++){
printf("%d", post_data[i]);
if(i != n-1)
printf(" ");
}
return true;
}
int main(){
cin >> n;
for(int i=0; i<n; i++)
cin >> dt[i];
flag = 1;
Tnode* root1 = Create();
PreOrder(root1);
if(Check(root1)){
return 0;
}
flag = 2;
Tnode* root2 = Create();
cnt = 0;
PreOrder(root2);
if(Check(root2)){
return 0;
}
printf("NO\n");
return 0;
}
|