IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> 1043 Is It a Binary Search Tree -> 正文阅读

[数据结构与算法]1043 Is It a Binary Search Tree

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.
Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

题意

给出N个正整数来作为一棵二叉排序树的结点插入顺序,问:这串序列是否是该二叉排序树的先序序列或是该二叉排序树的镜像树的先序序列。所谓镜像树是指交换二叉树的所有结点的左右子树而形成的树(也即左子树所有结点数据域大于或等于根结点,而根结点数据域小于右子树所有结点的数据域)。如果是镜像树,则输出 YES,并输出对应的树的后序序列;否则,输出NO。

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

思路

  1. 构建一颗二叉搜索树,判断其先序序列是否和输入顺序一样
  2. 若一样,输出YES,和后序序列;若不一样,检查其镜像二叉树,其余和1一样
  3. 构造镜像二叉树。
    法一:将原有的二叉搜索树,递归交换左右子树
    法二:再建立一颗树,建立时条件与1.相反
  4. 若镜像树先序和输入一样,输出YES和后序序列;不一样,输出NO,结束

注意

  1. 结尾无空格(PAT习惯)
  2. 插入相同元素时,按习惯是不插入,但这题要求插入到右边

代码

#include<iostream>
using namespace std;
int n, cnt = 0;
int dt[1001], pre_data[1001], post_data[1001];
int flag;
struct Tnode{
	int val;
	Tnode* left;
	Tnode* right;
	Tnode(int x) : val(x), left(NULL), right(NULL){}	//结构体构造函数 
};
/*用引用&方式插入节点,flag=1,正常BST;flag=2,镜像树*/
void Insert(Tnode* &root, int x){
	if(root == NULL){				//查找失败,插入位置
		root = new Tnode(x);
		return ;
	}
	if(flag == 1){
		if(root->val <= x) 
			Insert(root->right, x);//往右走
		else
			Insert(root->left, x);//往左走
	}
	else{							//镜像树 
		if(root->val > x) 
			Insert(root->right, x);//往右走
		else
			Insert(root->left, x);//往左走
	}
}
/*创建树,调用insert()*/
Tnode* Create(){
	Tnode* root = NULL;
	for(int i=0; i<n; i++)
		Insert(root, dt[i]);
	return root;
}
/*先序遍历,对节点的访问是放入pre_data[]里*/
void PreOrder(Tnode* root){
	if(root == NULL)
		return ;
	pre_data[cnt++] = root->val;
	PreOrder(root->left);
	PreOrder(root->right);
}
/*后序遍历,对节点的访问是放入post_data[]里*/
void PostOrder(Tnode* root){
	if(root == NULL)
		return ;
	PostOrder(root->left);
	PostOrder(root->right);
	post_data[cnt++] = root->val;
}
bool Check(Tnode* root){
    for(int i=0; i<n; i++){
        if(dt[i] != pre_data[i])
            return false;		//若先序对不上,退出 
    }
    printf("YES\n");			//若无错,开始后序 
    cnt = 0;
    PostOrder(root);
    for(int i=0; i<n; i++){
        printf("%d", post_data[i]);//输出后序节点,最后不要空格 
        if(i != n-1)
            printf(" ");
    }
    return true;				//这里忘记写,就报了段错误...... 
}
int main(){
	cin >> n;
	for(int i=0; i<n; i++)	//输入数据 
		cin >> dt[i];
	flag = 1;				//建BST树标记 
	Tnode* root1 = Create();//
	PreOrder(root1);
	if(Check(root1)){		//若BST匹配上了,直接返回,就不用建立镜像树了 
		return 0;
	}
	flag = 2;				//建立镜像树标记 
	Tnode* root2 = Create();
	cnt = 0;
	PreOrder(root2);
	if(Check(root2)){		//若BST镜像树匹配上了,直接返回 
		return 0;
	}
	printf("NO\n");			//前面两树先序都匹配失败,输出NO 
	return 0;
}
  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2022-03-16 22:43:30  更:2022-03-16 22:51:36 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 11:37:42-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码