IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> 基于链表的两个非递减有序序列的合并 -> 正文阅读

[数据结构与算法]基于链表的两个非递减有序序列的合并

将两个非递减有序序列合并为另一个非递增有序序列。

输入样例:
5 5
1 3 5 7 9
2 4 6 8 10
5 6
1 2 2 3 5
2 4 6 8 10 12
0 0

输出样例:
10 9 8 7 6 5 4 3 2 1
12 10 8 6 5 4 3 2 2 2 1

#include <stdio.h>
#include <stdlib.h>

typedef struct LNode {
    int data;
    struct LNode *next;
} LNode, *LinkList;

LinkList ListInit();
void ListDestroy(LinkList *head);
void ListTailInsert(LinkList head, int x);
void ListShow(LinkList head);
void ListMerge(LinkList A, LinkList B);
void ListInvert(LinkList head);

int main() {
    int m, n;

    while (scanf("%d %d%*c", &m, &n) && m && n) {
        LinkList A = ListInit();
        LinkList B = ListInit();
        int x;

        for (int i = 0; i < m; i++) {
            scanf("%d%*c", &x);
            ListTailInsert(A, x);
        }
        for (int i = 0; i < n; i++) {
            scanf("%d%*c", &x);
            ListTailInsert(B, x);
        }
        ListMerge(A, B);
        ListShow(A);
        ListDestroy(&A);
        ListDestroy(&B);
    }
    return 0;
}

LinkList ListInit() {
    LinkList head = (LinkList) malloc(sizeof(LNode));

    head->data = 0;
    head->next = NULL;
    return head;
}

void ListDestroy(LinkList *head) {
    LNode *tmp;

    while (*head) {
        tmp = *head;
        *head = (*head)->next;
        free(tmp);
    }
}

void ListTailInsert(LinkList head, int x) {
    LNode *newNode = (LNode *) malloc(sizeof(LNode)), *tail = head;

    newNode->data = x;
    newNode->next = NULL;
    while (tail->next) tail = tail->next;
    tail->next = newNode;
}

void ListShow(LinkList head) {
    for (LNode *cursor = head->next; cursor; cursor = cursor->next) {
        printf("%d%c", cursor->data, cursor->next ? 32 : 10);
    }
}

void ListMerge(LinkList A, LinkList B) {
    LNode *curA = A, *curB = B, *tmp;

    while (curA->next && curB->next) {
        if (curA->next->data < curB->next->data) {
            curA = curA->next;
        } else {
            /*将curB->next结点插入到curA->next位置*/
            tmp = curB->next->next;
            curB->next->next = curA->next;
            curA->next = curB->next;
            curB->next = tmp;
            curA = curA->next;
        }
    }
    if (curB->next) {
        curA->next = curB->next;
        curB->next = NULL;
    }
    ListInvert(A);
}

void ListInvert(LinkList head) {
    LNode *cursor = head->next, *tmp;

    head->next = NULL;
    while (cursor) {
        tmp = cursor->next;
        cursor->next = head->next;
        head->next = cursor;
        cursor = tmp;
    }
}
  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2022-03-17 22:25:52  更:2022-03-17 22:28:05 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 11:38:08-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码