D. 判断点线位置 (结构体+引用+函数)
题目描述
用具有x,y两个整型变量成员的结构类型SPoint来表示坐标点。用SLine结构类型来描述线段,其中包含p1和p2两个SPoint成员。
编写函数direction(const SLine &ab, const SPoint &c),利用向量ab与ac叉乘的值判断点c与直线ab的位置关系。
输入
判断次数
线的两点坐标x1、y1、x2、y2
点坐标x、y
......
输出
位置关系
输入样例1
3
1 5 2 9
1 3
5 6 7 8
6 7
2 3 1 0
3 3
输出样例1
clockwise
intersect
anti clockwise
提示
向量a(x1,y1)与向量b(x2,y2)的叉乘定义为a.x*b.y-a.y*b.x,若结果小于0,表示向量b在向量a的顺时针方向;若结果大于0,表示向量b在向量a的逆时针方向;若等于0,表示向量a与向量b平行。
该题比较简单,主要考察嵌套结构的使用?
#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<algorithm>
#include<string>
#include<vector>
#include <iomanip>
#include<cmath>
#include<cstring>
#include<cctype>
#include<queue>
#include<set>
using namespace std;
struct SPoint
{
int x;
int y;
};
struct SLine
{
SPoint p1;
SPoint p2;
};
int direction(const SLine& ab, const SPoint& c)
{
int num= (ab.p2.x - ab.p1.x) * (c.y - ab.p1.y) - (ab.p2.y - ab.p1.y) * (c.x - ab.p1.x);
if (num < 0)
{
return 1;
}
else if (num > 0)
{
return 3;
}
else
{
return 2;
}
}
int main()
{
int t,ans;
cin >> t;
SLine ab;
SPoint c;
while (t--)
{
cin >> ab.p1.x >> ab.p1.y >> ab.p2.x >> ab.p2.y;
cin >> c.x >> c.y;
ans = direction(ab, c);
if (ans == 1)
{
cout << "clockwise" << endl;
continue;
}
else if (ans == 2)
{
cout << "intersect" << endl;
continue;
}
else if (ans == 3)
{
cout << "anti clockwise" << endl;
continue;
}
}
return 0;
}
?
|