A dice game
描述
One day, boy A and girl B are playing a dice game. First, they write a number between 1~6 in a piece of paper, and then roll the dice. The one whose number is closer to the number of the dice will win this game. For example, A wins if |a-x|<|b-x|. And |a-x|=|b-x| means a draw.
输入
Each test case cantains two integers a and b, representing the numbers guessed by boy A and girl B respectively. The input is terminated in the end of file (EOF).
输出
For each test case, you must print the numbers of the cases of "A wins", "draw" and "B wins".
输入样例 1
2 5
输出样例 1
3 0 3
输入样例 2
2 4
输出样例 2
2 1 3
代码:
#include<iostream>
using namespace std;
int abs_x(int x) {//求绝对值函数
if (x < 0) x = -x;
return x;
}
int main() {
int a = 0;
int b = 0;
while (cin >> a >> b) {
int a1 = 0, b1 = 0, ab = 0;//分别代表a赢,b赢,平局的次数
for (int i = 1; i < 7; i++) {
if(abs_x(a - i) < (abs_x(b - i))) a1++;
else if(abs_x(a - i) > (abs_x(b - i))) b1++;
else ab++;
}
cout << a1 << " " << ab << " " << b1 << endl;
}
return 0;
}
|