IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> Ignatius and the Princess IV HDU - 1029 -> 正文阅读

[数据结构与算法]Ignatius and the Princess IV HDU - 1029

“OK, you are not too bad, em… But you can never pass the next test.” feng5166 says.

“I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers.” feng5166 says.

“But what is the characteristic of the special integer?” Ignatius asks.

“The integer will appear at least (N+1)/2 times. If you can’t find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha…” feng5166 says.

Can you find the special integer for Ignatius?
Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
Output
For each test case, you have to output only one line which contains the special number you have found.
Sample Input
5
1 2 3 3 3
11
1 1 1 1 1 7 7 7 7 7 7
5
1 1 1 1 1
Sample Output
3
7
1
——————————————分割线————————————————————
首先,欢迎HDUOJ 诈尸 复活,以后ACMer又有丰富的题做了。
激动之余,发一篇HDU的题解博客(水题)
题意大致为:给n个数 ,找出里面的众数。
一般思路为,定义一个最小值,遍历整个数组找出统计次数最多的元素。
但我们可以玩的SAO一点,用map来做,map会直接按照键值大小升序排列,但我们需要的是value值的大小。因此可以再用vector+pair进行倒腾。

#pragma GCC optimize(2)
#include <iostream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <algorithm>
#include <vector>
#define Buff std::ios::sync_with_stdio(false), cin.tie(0), cout.tie(0)
#define int long long
using namespace std;
int n;
typedef pair<int, int> PII;
bool cmp(PII a, PII b)
{
  return a.second < b.second;
}
signed main()
{
  Buff;
  while (cin >> n)
  {
    map<int, int> mp;
    vector<PII> arr;
    int cnt = 0;
    for (int i = 0; i < n; i++)
    {
      int x;
      cin >> x;
      mp[x]++;
    }
    for (auto it = mp.begin(); it != mp.end(); it++)
    {
      arr.push_back(make_pair(it->first, it->second));
    }
    sort(arr.begin(), arr.end(), cmp);
    auto t = arr.end()-1;//敲黑板!,容器的end为虚拟结尾需要减一
    cout << t->first << endl;//输出键值
  }
  return 0;
}

  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2022-04-01 00:19:45  更:2022-04-01 00:21:35 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 9:48:00-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码