A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.
Input Specification: Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K] where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.
The input ends with N being 0. That case must NOT be processed.
Output Specification: For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.
The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.
Sample Input:
2 1 01 1 02
Sample Output:
0 1
思路:给定一棵树,统计每层叶子节点个数,采用队列解决
AC代码;
#include<bits/stdc++.h>
using namespace std;
int n,m,t1,t2,ans,fg;
vector<int> vc[110];
queue<int> q;
int main()
{
cin>>n>>m;
for(int i=1;i<=m;i++)
{
int x,y,k;
cin>>x>>k;
for(int j=1;j<=k;j++)
{
cin>>y;
vc[x].push_back(y);
}
}
q.push(1);
t1=1;
while(q.size())
{
for(int i=1;i<=t1;i++)
{
if(!vc[q.front()].size())
ans++;
else
for(int j=0;j<vc[q.front()].size();j++)
{
q.push(vc[q.front()][j]);
t2++;
}
q.pop();
}
if(fg)
cout<<' ';
cout<<ans;
t1=t2;
ans=t2=0;
fg++;
}
}
|