IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> 【POJ P2411】【状压DP】Mondriaan‘s Dreamk -> 正文阅读

[数据结构与算法]【POJ P2411】【状压DP】Mondriaan‘s Dreamk

Mondriaan's Dream

POJ P2411 Mondriaan’s Dreamk


题目

Description

Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his ‘toilet series’ (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways.
在这里插入图片描述

Expert as he was in this material, he saw at a glance that he’ll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won’t turn into a nightmare!
在这里插入图片描述

Input

The input contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11.
Output

For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
Sample Input

1 2
1 3
1 4
2 2
2 3
2 4
2 11
4 11
0 0

Sample Output

1
0
1
2
3
5
144
51205

在这里插入图片描述


解题思路

设 f[i][j] 表示到第 i 行摆放方式为 j 的方案数
摆放状态用10表示

  • 1表示这里需要竖放向下突一格,当然要保证上行是0,一个0一个1用判断即可
  • 0有两种情况,一种是上行的这个位置是1,与上行并在一起
    还有就是要和左/右格并成一个横放,这里就必须要保证连在一起的0是偶数位,而且上行没有1凸出来拦截,可以提前预处理出‘0偶’的状态,然后在判断上行和下行出来是不是合法状态即可

Code

#include <iostream>
#include <cstring>
#include <cstdio>
#define ll long long

using namespace std;

ll n, m, f[20][1 << 15], c[1 << 15];

int main() {
	scanf("%lld %lld", &n, &m);
	while(n || m) {
		memset(c, 0, sizeof(c));
		for(int i = 0; i < (1 << m); i ++) {
			c[i] = 1;
			for(int j = 1; j <= m; j ++) {
				if((i >> (j - 1)) & 1) continue;
				int cnt = 1;
				while(j < m && !((i >> j) & 1)) j ++, cnt ++;  //统计 0 的个数
				if(cnt & 1) { c[i] = 0; break; }
			}
		}
		memset(f, 0, sizeof(f));
		f[0][0] = 1;
		for(int i = 1;  i <= n; i ++) {
			for(int x = 0; x < (1 << m); x ++) {  //上一行状态
				if(!f[i - 1][x]) continue;
				for(int y = 0; y < (1 << m); y ++)  //当前行状态
					if(!(x & y) && c[x | y]) f[i][y] +=f[i - 1][x];  //没有两个 1 ,且连在一起的 0 是合法的
			}
		}
		printf("%lld\n", f[n][0]);  //最后一行当然不能有凸下去的 1
		scanf("%lld %lld", &n, &m);
	}
}
  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2022-05-05 11:44:27  更:2022-05-05 11:48:50 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 5:36:58-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码