IT数码 购物 网址 头条 软件 日历 阅读 图书馆
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
图片批量下载器
↓批量下载图片,美女图库↓
图片自动播放器
↓图片自动播放器↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁
 
   -> 数据结构与算法 -> UVA10417 Gift Exchanging【概率】 -> 正文阅读

[数据结构与算法]UVA10417 Gift Exchanging【概率】

You’re attending a Xmas party, every one there (excepty you, I don’t know why…) has brought a beautiful little gift in a box. After all the gifts are collected and laid on the table, every one can choose one to take home. You are the first one to choose, so there is a big chance for you to get the gift that is brought by your best friend 😃
Unfortunately, you cannot see inside the gift box, but luckily, there are only 5 possible kinds of boxes allowed in the party. We use A, B, C, D, E to represent these five kinds. You know well about all the guests there. i.e you know the probability that each person brings each kind of box. Which box should you take home, and what is the probability that you get the one you want?
Input
The first line of the input is a single integer t (1 ≤ t ≤ 10), indicating the number of test cases. Each case begins with a line containing a single integer n (1 ≤ n ≤ 12), indicating the number of guests. The second line of the case contains 5 integers indicating the number of gifts of each kind. The sum of these 5 numbers always equals to n. The following n lines each contain 5 non-negative floating numbers (with one digit after decimal point) indicating the probabilities for him to take box A, B, C, D, E. The sum of 5 numbers always equals to 1.0. The first guest is your best friend.
Output
For each test case, print a single character indicating the box you should choose, then a single space, then the probability to 3 decimal places. If there are more than one best choices, print the smallest box number.
Sample Input
2
2
1 0 0 1 0
0.5 0.0 0.0 0.5 0.0
0.4 0.0 0.5 0.1 0.0
8
1 3 2 1 1
0.1 0.2 0.3 0.2 0.2
0.0 0.8 0.2 0.0 0.0
0.3 0.0 0.1 0.6 0.0
0.0 0.9 0.1 0.0 0.0
0.2 0.2 0.0 0.3 0.3
0.2 0.1 0.6 0.1 0.0
0.7 0.2 0.1 0.0 0.0
0.1 0.0 0.0 0.2 0.7
Sample Output
4 0.800
3 0.296

问题链接UVA10417 Gift Exchanging
问题简述:(略)
问题分析:概率计算问题,不解释。解题代码来自仙客传奇团队。
程序说明:(略)
参考链接:(略)
题记:(略)

AC的C++语言程序如下:

/* UVA10417 Gift Exchanging */

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

const int N = 5;
const int M=15;
const double EPS = 1e-9;
double p[M][N], res[N];
int n, t, cnt[N];

double dfs(int cur, double prob)
{
    if (cur == n) return prob;

    double ans = 0;
    for (int i = 0; i < N; i++)
        if(cnt[i] && p[cur][i] > EPS) {
            cnt[i]--;

            double tmp = dfs(cur + 1, prob * p[cur][i]);
            ans += tmp;
            if (cur == 0) res[i] += tmp;
            cnt[i]++;
        }
    return ans;
}

int main()
{
    scanf("%d", &t);
    while (t--) {
         scanf("%d", &n);
         for (int i = 0; i < N; i++)
             scanf("%d", &cnt[i]);
         for (int i = 0; i < n; i++)
             for (int j = 0; j < N; j++)
                 scanf("%lf", &p[i][j]);

         memset(res, 0, sizeof(res));
         double all = dfs(0, 1);

         int id=0;
         double ans=0;
         for (int i = 0; i < N; i++) {
             double tmp = res[i] / cnt[i];  //从该包装中所有礼物恰好能选到bf送的礼物概率为1/cnt[i]
             if (tmp - ans > EPS)
                 id = i, ans = tmp;
         }

         printf("%d %.3f\n", id + 1, ans / all);
    }

    return 0;
}
  数据结构与算法 最新文章
【力扣106】 从中序与后续遍历序列构造二叉
leetcode 322 零钱兑换
哈希的应用:海量数据处理
动态规划|最短Hamilton路径
华为机试_HJ41 称砝码【中等】【menset】【
【C与数据结构】——寒假提高每日练习Day1
基础算法——堆排序
2023王道数据结构线性表--单链表课后习题部
LeetCode 之 反转链表的一部分
【题解】lintcode必刷50题<有效的括号序列
上一篇文章      下一篇文章      查看所有文章
加:2022-05-09 12:59:06  更:2022-05-09 13:01:56 
 
开发: C++知识库 Java知识库 JavaScript Python PHP知识库 人工智能 区块链 大数据 移动开发 嵌入式 开发工具 数据结构与算法 开发测试 游戏开发 网络协议 系统运维
教程: HTML教程 CSS教程 JavaScript教程 Go语言教程 JQuery教程 VUE教程 VUE3教程 Bootstrap教程 SQL数据库教程 C语言教程 C++教程 Java教程 Python教程 Python3教程 C#教程
数码: 电脑 笔记本 显卡 显示器 固态硬盘 硬盘 耳机 手机 iphone vivo oppo 小米 华为 单反 装机 图拉丁

360图书馆 购物 三丰科技 阅读网 日历 万年历 2024年11日历 -2024/11/26 3:26:38-

图片自动播放器
↓图片自动播放器↓
TxT小说阅读器
↓语音阅读,小说下载,古典文学↓
一键清除垃圾
↓轻轻一点,清除系统垃圾↓
图片批量下载器
↓批量下载图片,美女图库↓
  网站联系: qq:121756557 email:121756557@qq.com  IT数码