目录
题目
思路
代码
题目
题目描述
图的广度优先搜索类似于树的按层次遍历,即从某个结点开始,先访问该结点,然后访问该结点的所有邻接点,再依次访问各邻接点的邻接点。如此进行下去,直到所有的结点都访问为止。在该题中,假定所有的结点以“A”--“Z”中的若干字符表示,且要求结点的访问顺序根据录入的顺序进行访问。如果结点录入的顺序为HUEAK,要求从H开始进行广度优先搜索,则可能的搜索结果为:H->E->A->U->K.
输入
第一行为一个整数n,表示顶点的个数,第二行为n个大写字母构成的字符串,表示顶点,接下来是为一个n*n大小的整数矩阵,表示图的邻接关系。数字为0表示不邻接,否则为相应的边的长度。最后一行为一个字符,表示要求进行广度优先搜索的起始顶点。
输出
用一行输出广度优先搜索结果,起始点为给定的顶点。
样例输入
5
HUEAK
0 0 2 3 0
0 0 0 7 4
2 0 0 0 0
3 7 0 0 1
0 4 0 1 0
H
样例输出
HEAUK
思路
图的广搜介绍
代码
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <vector>
#include <queue>
#define endl '\n'
#define N 10005
typedef long long ll;
using namespace std;
string s;
vector<int>G[N];
queue<int>ans;
bool vis[N];
int main() {
int n;cin>>n>>s;
for(int i=0;i<n;i++) {
for(int j=0;j<n;j++) {
int x;cin>>x;
if(x) G[i].push_back(j);
}
}
char c;cin>>c;
int key=0;
while(c!=s[key++]);
vis[key-1]=1;
ans.push(key-1);
while(!ans.empty()) {
cout<<s[ans.front()];
for(int i=0;i<G[ans.front()].size();i++) {
if(vis[G[ans.front()][i]]==0) {
ans.push(G[ans.front()][i]);
vis[G[ans.front()][i]]=1;
}
}
ans.pop();
}
return 0;
}
|