静态链表
今天做数据结构链表的题发现了两个关于静态链表的题,我寻思着,啥叫静态链表啊,还让输入数据地址和下一个地址的数据
哦哦哦哦哦,原来就是个结构体数组,下面就由一个题来介绍链表,啊呸,结构体数组吧
相关题目:
链表去重
给定一个带整数键值的链表 L,你需要把其中绝对值重复的键值结点删掉。即对每个键值 K,只有第一个绝对值等于 K 的结点被保留。同时,所有被删除的结点须被保存在另一个链表上。例如给定 L 为 21→-15→-15→-7→15,你需要输出去重后的链表 21→-15→-7,还有被删除的链表 -15→15。
输入格式:
输入在第一行给出 L 的第一个结点的地址和一个正整数 N(≤105,为结点总数)。一个结点的地址是非负的 5 位整数,空地址 NULL 用 -1 来表示。
随后 N 行,每行按以下格式描述一个结点:
地址 键值 下一个结点
其中地址 是该结点的地址,键值 是绝对值不超过104的整数,下一个结点 是下个结点的地址。
输出格式:
首先输出去重后的链表,然后输出被删除的链表。每个结点占一行,按输入的格式输出。
输入样例:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854
输出样例:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1
详解:
#include <iostream>
#include <string.h>
using namespace std;
struct node
{
int data;
int nextAdd;
} list[120000];
bool flag[50000];
void Initinitalizelist(int head, int N)
{
int address, Data, nextadd;
for (int i = 1; i <= N; i++)
{
cin >> address >> Data >> nextadd;
list[address].data = Data;
list[address].nextAdd = nextadd;
}
}
int DeleteList(int head)
{
memset(flag, 0, sizeof(flag));
int lastAddress = -1
,
headleave = -1
,
tail = -1
,
firstdel = 1;
int i = head;
while (i != -1)
{
if (flag[abs(list[i].data)] == false)
{
flag[abs(list[i].data)] = true;
lastAddress = i;
}
else
{
list[lastAddress].nextAdd = list[i].nextAdd;
if (firstdel == 1)
{
headleave = i;
tail = headleave;
firstdel = 0;
}
else
{
list[tail].nextAdd = i;
tail = i;
}
}
i = list[i].nextAdd;
}
list[tail].nextAdd = -1;
return headleave;
}
void printList(int headdel, int head)
{
for (int i = head; i != -1; i = list[i].nextAdd)
{
printf("%05d %d ", i, list[i].data);
if (list[i].nextAdd == -1)
printf("-1\n");
else
printf("%05d\n", list[i].nextAdd);
}
for (int i = headdel; i != -1; i = list[i].nextAdd)
{
printf("%05d %d ", i, list[i].data);
if (list[i].nextAdd == -1)
printf("-1\n");
else
printf("%05d\n", list[i].nextAdd);
}
}
int main()
{
int head, N, headdel;
cin >> head >> N;
Initinitalizelist(head, N);
headdel = DeleteList(head);
printList(headdel, head);
system("pause");
}
重排链表:
给定一个单链表 L1→L2→?→L**n?1→L**n,请编写程序将链表重新排列为 L**n→L1→L**n?1→L2→?。例如:给定L为1→2→3→4→5→6,则输出应该为6→1→5→2→4→3。
输入格式:
每个输入包含1个测试用例。每个测试用例第1行给出第1个结点的地址和结点总个数,即正整数N (≤105)。结点的地址是5位非负整数,NULL地址用?1表示。
接下来有N行,每行格式为:
Address Data Next
其中Address 是结点地址;Data 是该结点保存的数据,为不超过105的正整数;Next 是下一结点的地址。题目保证给出的链表上至少有两个结点。
输出格式:
对每个测试用例,顺序输出重排后的结果链表,其上每个结点占一行,格式与输入相同。
输入样例:
00100 6
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
输出样例:
68237 6 00100
00100 1 99999
99999 5 12309
12309 2 00000
00000 4 33218
33218 3 -1
我写的
#include <iostream>
#include <string.h>
using namespace std;
struct node
{
int data;
int nextAdd;
int befAdd;
} list[100001];
int countn;
void Initinitalizelist(int head, int N)
{
int address, Data, nextadd;
countn = N;
for (int i = 1; i <= N; i++)
{
cin >> address >> Data >> nextadd;
list[address].data = Data;
list[address].nextAdd = nextadd;
list[list[address].nextAdd].befAdd = address;
}
}
void relist(int head)
{
int lastp, headp;
headp = head;
lastp = head;
while (list[lastp].nextAdd != -1)
{
lastp = list[lastp].nextAdd;
}
while (headp != list[lastp].befAdd && lastp != list[headp].nextAdd && headp != lastp)
{
printf("%05d %d %05d\n", lastp, list[lastp].data, headp);
lastp = list[lastp].befAdd;
printf("%05d %d %05d\n", headp, list[headp].data, lastp);
headp = list[headp].nextAdd;
}
if (countn % 2 == 0)
{
printf("%05d %d %05d\n", lastp, list[lastp].data, list[lastp].befAdd);
}
printf("%05d %d ", headp, list[headp].data);
printf("-1\n");
}
int main()
{
int head, N, headdel;
cin >> head >> N;
Initinitalizelist(head, N);
relist(head);
system("pause");
}
真的,这个测试点二是一个奇数测试点,卡了我半天,我这个方法不是最好的但是过了,这个debug了半天自己写的。还有用队列用别的判断方式的咕噜噜
|